aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python25
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
committerlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
commit2cfa567e139ca7fea8a95b3ae3875c03cb89465d (patch)
tree174b3e926e8901d35bbbf36e21e4e137d514b364 /lang/python25
parente5cfe7554656b5ddebd24975ece0d4d4658e8d90 (diff)
downloadfreebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.gz
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.zst
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.zip
- Remove the HUGE_STACK_SIZE option, now Python will use default
thread stack size of the system.
Diffstat (limited to 'lang/python25')
-rw-r--r--lang/python25/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 7fd4f7ee198c..0a0560ced7a7 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5.6
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -47,7 +48,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -68,11 +68,6 @@ CFLAGS+= -D__wchar_t=wchar_t
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+= --without-threads