aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python26/Makefile
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1996-01-18 18:18:54 +0800
committerjkh <jkh@FreeBSD.org>1996-01-18 18:18:54 +0800
commitf64c1c512eca77b00f253bda3caaace9c8c56ca9 (patch)
tree0aae4d15385595ec8c847fe0e0d3b5fdb9538fd3 /lang/python26/Makefile
parent8dd867e73e8fcedd18decf2715bab2826f526465 (diff)
downloadfreebsd-ports-gnome-f64c1c512eca77b00f253bda3caaace9c8c56ca9.tar.gz
freebsd-ports-gnome-f64c1c512eca77b00f253bda3caaace9c8c56ca9.tar.zst
freebsd-ports-gnome-f64c1c512eca77b00f253bda3caaace9c8c56ca9.zip
Update to Python 1.3
Submitted by: tg
Diffstat (limited to 'lang/python26/Makefile')
-rw-r--r--lang/python26/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 502235016a44..2fe0727106d7 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -3,26 +3,33 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.2 1995/08/09 01:30:00 asami Exp $
+# $Id: Makefile,v 1.3 1995/11/22 13:13:06 asami Exp $
#
-DISTNAME= python1.2
-PKGNAME= python-1.2
+DISTNAME= python1.3
+PKGNAME= python-1.3
CATEGORIES+= lang
-MASTER_SITES= ftp://www.python.org/pub/python/src/
+MASTER_SITES= ftp://www.python.org/pub/python/src/ \
+ ftp://ftp.cwi.nl/pub/python/src/
MAINTAINER= jkh@FreeBSD.org
-LIB_DEPENDS= tcl\\.7\\.:${PORTSDIR}/lang/tcl \
- tk\\.3\\.:${PORTSDIR}/x11/tk
+LIB_DEPENDS= tcl74\\.1\\.:${PORTSDIR}/lang/tcl74 \
+ tk40\\.1\\.:${PORTSDIR}/x11/tk4
+
+WRKSRC= ${WRKDIR}/Python-1.3
+HAS_CONFIGURE= yes
+
+MAKE_FLAGS+= 'OPT=${CFLAGS}'
+INSTALL_TARGET= install libinstall maninstall
post-configure:
cp ${FILESDIR}/Setup ${WRKSRC}/Modules
-pre-install:
- cd ${WRKSRC}; ${MAKE} libinstall
-
-WRKSRC= ${WRKDIR}/Python-1.2
-HAS_CONFIGURE= yes
+post-install:
+ strip ${PREFIX}/bin/python
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/python.1
+.endif
.include <bsd.port.mk>