aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python26
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
committerlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
commit2cfa567e139ca7fea8a95b3ae3875c03cb89465d (patch)
tree174b3e926e8901d35bbbf36e21e4e137d514b364 /lang/python26
parente5cfe7554656b5ddebd24975ece0d4d4658e8d90 (diff)
downloadfreebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.gz
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.zst
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.zip
- Remove the HUGE_STACK_SIZE option, now Python will use default
thread stack size of the system.
Diffstat (limited to 'lang/python26')
-rw-r--r--lang/python26/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index dfc413af7b28..38be184fff72 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python26
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -48,7 +49,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
SEM "Use POSIX semaphores (experimental)" off \
PTH "Use GNU Pth for threading/multiprocessing" off \
UCS4 "Use UCS4 for unicode support" on \
@@ -96,11 +96,6 @@ CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.endif # defined(WITH_PTH)
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "
CONFIGURE_ARGS+= --without-threads