aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27/files
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-05-17 12:17:22 +0800
committerrm <rm@FreeBSD.org>2013-05-17 12:17:22 +0800
commit060ea88a780b6a26d97ff495accc2d252f549f90 (patch)
tree2d90e75b4dd432723e621b65ad4e2e51b8a4e421 /lang/python27/files
parentafc5551bbb56a8a02602d565e8983af6e04bde74 (diff)
downloadfreebsd-ports-gnome-060ea88a780b6a26d97ff495accc2d252f549f90.tar.gz
freebsd-ports-gnome-060ea88a780b6a26d97ff495accc2d252f549f90.tar.zst
freebsd-ports-gnome-060ea88a780b6a26d97ff495accc2d252f549f90.zip
- update to latest upstream versions:
. lang/python27: 2.7.3 -> 2.7.5 . lang/python32: 3.2.3 -> 3.2.4 . lang/python33: 3.3.0 -> 3.3.1 - update Mk/bsd.python.mk with new versions - mark lang/python26 and lang/python31 as deprecated (set them to upstream EoL dates) - update docs (lang/python-doc-html) - align databases/py-bsddb patch for python27 - most of it was applied upstream. Raise BDB version to 4.3 atleast, according to upstream requirements. Many thanks to Martin (miwi) for his time on this update. PR: 178506 Submitted by: rm (myself) Exp-run by: portmgr (miwi) - revert erroneous threads patch in lang/python26 and lang/python27, that was added after ports/131080. It was rejected upstream, because it's not actually a bug, but misuse. Gabor Pali (pgj) in collaboration with Kubilay Kocak (koobs) did an independent investigation regard the issue. See here for details: http://lists.freebsd.org/pipermail/freebsd-python/2013-April/005376.html PR: 153167 Submitted by: Duncan Findlay <duncan@duncf.ca> Reported by: pgj/koobs (at python@ ML) Exp-run by: portmgr (miwi)
Diffstat (limited to 'lang/python27/files')
-rw-r--r--lang/python27/files/extra-patch-setup.py14
-rw-r--r--lang/python27/files/patch-Makefile.pre.in14
-rw-r--r--lang/python27/files/patch-Python_thread__pthread.h55
-rw-r--r--lang/python27/files/patch-setup.py46
4 files changed, 44 insertions, 85 deletions
diff --git a/lang/python27/files/extra-patch-setup.py b/lang/python27/files/extra-patch-setup.py
index 98fd1a8b3621..63e7f032e336 100644
--- a/lang/python27/files/extra-patch-setup.py
+++ b/lang/python27/files/extra-patch-setup.py
@@ -1,11 +1,11 @@
---- setup.py.bak 2010-08-15 14:57:00.347134100 +0800
-+++ setup.py 2010-08-15 15:00:06.019643300 +0800
-@@ -1402,10 +1402,22 @@
+--- setup.py.orig 2013-04-07 11:07:43.000000000 +0400
++++ setup.py 2013-04-07 11:16:36.000000000 +0400
+@@ -1544,10 +1544,22 @@
macros = dict()
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
+- elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
++ elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
- macros = dict()
@@ -16,7 +16,7 @@
+ )
+ libraries = []
+
-+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
++ elif host_platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+ macros = dict( # FreeBSD 7+
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=1,
@@ -24,4 +24,4 @@
+ )
libraries = []
- elif platform.startswith('openbsd'):
+ elif host_platform.startswith('openbsd'):
diff --git a/lang/python27/files/patch-Makefile.pre.in b/lang/python27/files/patch-Makefile.pre.in
new file mode 100644
index 000000000000..ff18787b8a2c
--- /dev/null
+++ b/lang/python27/files/patch-Makefile.pre.in
@@ -0,0 +1,14 @@
+--- ./Makefile.pre.in.orig 2013-04-06 18:02:34.000000000 +0400
++++ ./Makefile.pre.in 2013-04-07 22:30:19.000000000 +0400
+@@ -281,9 +281,9 @@
+
+ ##########################################################################
+ # AST
+-AST_H_DIR= Include
++AST_H_DIR= $(srcdir)/Include
+ AST_H= $(AST_H_DIR)/Python-ast.h
+-AST_C_DIR= Python
++AST_C_DIR= $(srcdir)/Python
+ AST_C= $(AST_C_DIR)/Python-ast.c
+ AST_ASDL= $(srcdir)/Parser/Python.asdl
+
diff --git a/lang/python27/files/patch-Python_thread__pthread.h b/lang/python27/files/patch-Python_thread__pthread.h
deleted file mode 100644
index 67355d496333..000000000000
--- a/lang/python27/files/patch-Python_thread__pthread.h
+++ /dev/null
@@ -1,55 +0,0 @@
---- Python/thread_pthread.h.orig 2010-05-09 22:46:46.000000000 +0800
-+++ Python/thread_pthread.h 2010-08-15 14:27:51.886823397 +0800
-@@ -26,13 +26,18 @@
- #endif
- #endif
-
-+#ifdef __FreeBSD__
-+#include <osreldate.h>
-+#endif
-+
- /* The POSIX spec says that implementations supporting the sem_*
- family of functions must indicate this by defining
- _POSIX_SEMAPHORES. */
- #ifdef _POSIX_SEMAPHORES
- /* On FreeBSD 4.x, _POSIX_SEMAPHORES is defined empty, so
- we need to add 0 to make it work there as well. */
--#if (_POSIX_SEMAPHORES+0) == -1
-+#if defined(__FreeBSD__) && __FreeBSD_version < 701104 && \
-+ (_POSIX_SEMAPHORES+0) == -1
- #define HAVE_BROKEN_POSIX_SEMAPHORES
- #else
- #include <semaphore.h>
-@@ -44,7 +49,6 @@
- in default setting. So the process scope is preferred to get
- enough number of threads to work. */
- #ifdef __FreeBSD__
--#include <osreldate.h>
- #if __FreeBSD_version >= 500000 && __FreeBSD_version < 504101
- #undef PTHREAD_SYSTEM_SCHED_SUPPORTED
- #endif
-@@ -149,6 +153,7 @@
- {
- pthread_t th;
- int status;
-+ sigset_t set, oset;
- #if defined(THREAD_STACK_SIZE) || defined(PTHREAD_SYSTEM_SCHED_SUPPORTED)
- pthread_attr_t attrs;
- #endif
-@@ -177,6 +182,8 @@
- #if defined(PTHREAD_SYSTEM_SCHED_SUPPORTED)
- pthread_attr_setscope(&attrs, PTHREAD_SCOPE_SYSTEM);
- #endif
-+ sigfillset(&set);
-+ SET_THREAD_SIGMASK(SIG_BLOCK, &set, &oset);
-
- status = pthread_create(&th,
- #if defined(THREAD_STACK_SIZE) || defined(PTHREAD_SYSTEM_SCHED_SUPPORTED)
-@@ -188,6 +195,7 @@
- (void *)arg
- );
-
-+ SET_THREAD_SIGMASK(SIG_SETMASK, &oset, NULL);
- #if defined(THREAD_STACK_SIZE) || defined(PTHREAD_SYSTEM_SCHED_SUPPORTED)
- pthread_attr_destroy(&attrs);
- #endif
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index f793c0bb19f1..5fee8c2c1302 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -1,7 +1,7 @@
---- setup.py.orig 2011-06-11 17:46:28.000000000 +0200
-+++ setup.py 2011-10-18 12:05:34.000000000 +0200
-@@ -21,7 +21,7 @@
- COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount')
+--- setup.py.orig 2013-04-06 18:02:41.000000000 +0400
++++ setup.py 2013-04-07 10:52:47.000000000 +0400
+@@ -33,7 +33,7 @@
+ COMPILED_WITH_PYDEBUG = ('--with-pydebug' in sysconfig.get_config_var("CONFIG_ARGS"))
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
@@ -9,7 +9,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -642,7 +642,7 @@
+@@ -720,7 +720,7 @@
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
curses_library = readline_termcap_library
@@ -18,16 +18,16 @@
curses_library = 'ncursesw'
elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
curses_library = 'ncurses'
-@@ -681,7 +681,7 @@
+@@ -755,7 +755,7 @@
+ elif curses_library:
+ readline_libs.append(curses_library)
+ elif self.compiler.find_library_file(lib_dirs +
+- ['/usr/lib/termcap'],
++ ['/usr/lib', '/usr/lib/termcap'],
'termcap'):
readline_libs.append('termcap')
exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/lib/termcap'],
-+ library_dirs=['/usr/lib', '/usr/lib/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- else:
-@@ -783,6 +783,8 @@
+@@ -862,6 +862,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
@@ -36,7 +36,7 @@
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
-@@ -1120,7 +1122,7 @@
+@@ -1208,7 +1210,7 @@
sysroot = macosx_sdk_root()
f = os.path.join(sysroot, f[1:])
@@ -45,7 +45,7 @@
data = open(f).read()
m = re.search(r"#s*define\s+HASHVERSION\s+2\s*", data)
if m is not None:
-@@ -1246,12 +1248,13 @@
+@@ -1338,12 +1340,13 @@
# provided by the ncurses library.
panel_library = 'panel'
if curses_library.startswith('ncurses'):
@@ -58,9 +58,9 @@
exts.append( Extension('_curses', ['_cursesmodule.c'],
+ library_dirs = ['/usr/lib'],
libraries = curses_libs) )
- elif curses_library == 'curses' and platform != 'darwin':
+ elif curses_library == 'curses' and host_platform != 'darwin':
# OSX has an old Berkeley curses, not good enough for
-@@ -1264,6 +1267,7 @@
+@@ -1356,6 +1359,7 @@
curses_libs = ['curses']
exts.append( Extension('_curses', ['_cursesmodule.c'],
@@ -68,25 +68,25 @@
libraries = curses_libs) )
else:
missing.append('_curses')
-@@ -1432,7 +1436,7 @@
+@@ -1540,7 +1544,7 @@
macros = dict()
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+- elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
++ elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
-@@ -1484,7 +1488,7 @@
+@@ -1592,7 +1596,7 @@
missing.append('linuxaudiodev')
- if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
+ if (host_platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8')
+ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10')
- or platform.startswith("gnukfreebsd")):
+ or host_platform.startswith("gnukfreebsd")):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
-@@ -2066,9 +2070,7 @@
+@@ -2176,9 +2180,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install