aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27/files
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-09 22:29:18 +0800
committerperky <perky@FreeBSD.org>2006-10-09 22:29:18 +0800
commitd8375e2f132ee1ab132e35b9297f579a306103c0 (patch)
tree18e859ce440a43ead22e95cbc34b5c77e7997fc7 /lang/python27/files
parent6d4c50c79be21174771ec26c76d927e4516ce528 (diff)
downloadfreebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.tar.gz
freebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.tar.zst
freebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.zip
- Update the main python version to 2.5.
- Now, lang/python is just a meta-port which depends on lang/python25. - And all versions of Python ports have short version identifier in its package name; python25-2.5, python24-2.4.3 and etc. - Also you must upgrade all python modules after lang/python updated, cd /usr/ports/lang/python && make upgrade-site-packages - Give maintainership of Python ports to the new python@ group which includes me, alexbl@ and others.
Diffstat (limited to 'lang/python27/files')
-rw-r--r--lang/python27/files/patch-setup.py23
1 files changed, 11 insertions, 12 deletions
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index cf0beedab0c6..07708de2c558 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Fri Jun 30 15:18:39 2006
-+++ setup.py Thu Aug 10 18:41:33 2006
+--- setup.py.orig Thu Aug 10 08:42:18 2006
++++ setup.py Thu Oct 5 13:26:43 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -18,13 +18,12 @@
# Modules that provide persistent dictionary-like semantics. You will
-@@ -1498,8 +1500,7 @@
- ext_modules=[Extension('_struct', ['_struct.c'])],
-
- # Scripts to install
-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
-- 'Lib/smtpd.py']
-+ scripts = []
- )
-
- # --install-platlib
+@@ -903,7 +905,7 @@
+ # Curses support, requiring the System V version of curses, often
+ # provided by the ncurses library.
+ panel_library = 'panel'
+- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
++ if (self.compiler.find_library_file(lib_dirs, 'xxxncursesw')):
+ curses_libs = ['ncursesw']
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.