aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python30
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-13 15:16:45 +0800
committerperky <perky@FreeBSD.org>2006-10-13 15:16:45 +0800
commit3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589 (patch)
tree6c46f1d5bf4bc63b89ba8a1cd88a3898b2377fbc /lang/python30
parente7f318bbbc010a1cc2d2a35dcd0ccf78ca6656c2 (diff)
downloadfreebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.tar.gz
freebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.tar.zst
freebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.zip
Revert the default version of Python to 2.4 for the ports freeze
period. Python 2.5 brought a vast range of incompatibility to a large number of ports, so the python@ team will do more basic compatibility work in a private repository and merge it later. Sorry for the inconvenience. Approved by: portmgr (kris)
Diffstat (limited to 'lang/python30')
-rw-r--r--lang/python30/Makefile10
-rw-r--r--lang/python30/files/patch-setup.py10
-rw-r--r--lang/python30/pkg-plist7
3 files changed, 13 insertions, 14 deletions
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
diff --git a/lang/python30/files/patch-setup.py b/lang/python30/files/patch-setup.py
index 07708de2c558..4ed6f0f38c8e 100644
--- a/lang/python30/files/patch-setup.py
+++ b/lang/python30/files/patch-setup.py
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+-@@ -1498,8 +1500,7 @@
+- ext_modules=[Extension('_struct', ['_struct.c'])],
+-
+- # Scripts to install
+-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+-- 'Lib/smtpd.py']
+-+ scripts = []
+- )
+-
+- # --install-platlib
diff --git a/lang/python30/pkg-plist b/lang/python30/pkg-plist
index 3fe55a543fbe..6526f34bc484 100644
--- a/lang/python30/pkg-plist
+++ b/lang/python30/pkg-plist
@@ -1,17 +1,10 @@
-bin/idle
bin/idle%%PYVER%%
-bin/pydoc
bin/pydoc%%PYVER%%
-bin/python
bin/python%%PYVER%%
bin/python%%PYVER%%-config
-bin/python-config
-bin/python-shared
bin/python-shared%%PYVER%%
bin/python-shared%%PYVER%%-config
-bin/python-shared-config
bin/smtpd%%PYVER%%.py
-bin/smtpd.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h
%%PYTHON_INCLUDEDIR%%/abstract.h