aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python31/files
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-08-10 18:05:13 +0800
committerperky <perky@FreeBSD.org>2006-08-10 18:05:13 +0800
commitad2be0865518c747c5d9121d00a81115aa2d6a27 (patch)
tree9f36916d73fb6276b447bc0ddeb5afec65d514d1 /lang/python31/files
parentb453b092e46b857405b14438988e4140f279568f (diff)
downloadfreebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.tar.gz
freebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.tar.zst
freebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.zip
Fix plist for FreeBSD 7 or systems with OpenSSL 0.9.8.
Spotted by: pointyhat via kris
Diffstat (limited to 'lang/python31/files')
-rw-r--r--lang/python31/files/patch-setup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/python31/files/patch-setup.py b/lang/python31/files/patch-setup.py
index ebf70e88cb39..cf0beedab0c6 100644
--- a/lang/python31/files/patch-setup.py
+++ b/lang/python31/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Tue Jun 6 08:38:06 2006
-+++ setup.py Fri Jun 23 11:02:35 2006
+--- setup.py.orig Fri Jun 30 15:18:39 2006
++++ setup.py Thu Aug 10 18:41:33 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -1470,8 +1470,7 @@
+@@ -590,6 +590,8 @@
+ # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
+ exts.append( Extension('_sha256', ['sha256module.c']) )
+ exts.append( Extension('_sha512', ['sha512module.c']) )
++ else:
++ open('.without_own_sha', 'w')
+
+
+ # Modules that provide persistent dictionary-like semantics. You will
+@@ -1498,8 +1500,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install