aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-09 22:29:18 +0800
committerperky <perky@FreeBSD.org>2006-10-09 22:29:18 +0800
commitd8375e2f132ee1ab132e35b9297f579a306103c0 (patch)
tree18e859ce440a43ead22e95cbc34b5c77e7997fc7 /lang/python32/Makefile
parent6d4c50c79be21174771ec26c76d927e4516ce528 (diff)
downloadfreebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.tar.gz
freebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.tar.zst
freebsd-ports-gnome-d8375e2f132ee1ab132e35b9297f579a306103c0.zip
- Update the main python version to 2.5.
- Now, lang/python is just a meta-port which depends on lang/python25. - And all versions of Python ports have short version identifier in its package name; python25-2.5, python24-2.4.3 and etc. - Also you must upgrade all python modules after lang/python updated, cd /usr/ports/lang/python && make upgrade-site-packages - Give maintainership of Python ports to the new python@ group which includes me, alexbl@ and others.
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 01f4de5cccf4..8831de95431e 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -1,17 +1,17 @@
-# New ports collection makefile for: python-devel
+# New ports collection makefile for: python25
# Date created: 3 July 2003
# Whom: Hye-Shik Chang <perky@FreeBSD.org>
#
# $FreeBSD$
-PORTNAME= python
-PORTVERSION= 2.5.c2
+PORTNAME= python25
+PORTVERSION= 2.5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
DISTFILES= ${PYTHON_DISTFILE}
-MAINTAINER= perky@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
@@ -23,8 +23,8 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= altinstall
-MAN1= ${PYTHON_VERSION}.1
+INSTALL_TARGET= install
+MAN1= python.1 ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
@@ -33,7 +33,7 @@ LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
-PLIST_TEMPLATE= ${PKGDIR}/pkg-plist
+PLIST_TEMPLATE?=${PKGDIR}/pkg-plist
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
PYVER_WITHPAT=${PORTVERSION:S/.c/c/}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
@@ -202,6 +202,10 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
+ cd ${PREFIX}/bin; \
+ ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
+ ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
+ python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \
@@ -219,4 +223,6 @@ post-install:
(cd ${DEMODIR}; ${TAR} -xf -)
.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>