aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-07-08 23:53:45 +0800
committerperky <perky@FreeBSD.org>2004-07-08 23:53:45 +0800
commit66b96333f39117f328d1f551cb32af1fc62004aa (patch)
tree85db84871fd4b6df4dfc01f5d79ae3d736055c6a /lang/python32/Makefile
parent8096700f41192e869e0dc3addabde5d5708f8e2f (diff)
downloadfreebsd-ports-gnome-66b96333f39117f328d1f551cb32af1fc62004aa.tar.gz
freebsd-ports-gnome-66b96333f39117f328d1f551cb32af1fc62004aa.tar.zst
freebsd-ports-gnome-66b96333f39117f328d1f551cb32af1fc62004aa.zip
- Update to 2.4a1, the first alpha release of Python 2.4.
- Provide USE_PYTHON_BUILD and USE_PYTHON_RUN to allow explicit dependencies. [1] - Provide PYDISTUTILS_CONFIGUREARGS and run ${PYSETUP} config on 'do-configure' targets. [2] Reviewed by: eik [1] Submitted by: Mike Brown <mike@skew.org>
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8c2b27bc134d..a9c98c31e232 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= python
-PORTVERSION= 2.4.a0.20040311
+PORTVERSION= 2.4.a1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -115,6 +115,8 @@ post-extract:
${WRKSRC}/Tools/scripts/pydoc > ${WRKDIR}/pydoc2.4
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
${WRKSRC}/Tools/scripts/idle > ${WRKDIR}/idle2.4
+ ${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
+ ${WRKSRC}/Lib/smtpd.py > ${WRKDIR}/smtpd2.4.py
post-patch:
${REINPLACE_CMD} -e 's,\(PY_VERSION.*\)2\.4a0,\1${PORTVERSION},g' \
@@ -170,7 +172,7 @@ post-install:
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
- ${PREFIX}/bin
+ ${WRKDIR}/smtpd2.4.py ${PREFIX}/bin
@${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/Misc/python.man \
${MANPREFIX}/man/man1/${PYTHON_VERSION}.1