aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-06-28 14:24:11 +0800
committerperky <perky@FreeBSD.org>2004-06-28 14:24:11 +0800
commit118895acfcb43f931d9d08b7ab973e18568e9b82 (patch)
tree4cb2cbecbf9b3e14fd9024d8cc8ecc543c480278 /lang/python32
parent7953be5f9a39fdee8ac61767d277c7d4d258c6f5 (diff)
downloadfreebsd-ports-gnome-118895acfcb43f931d9d08b7ab973e18568e9b82.tar.gz
freebsd-ports-gnome-118895acfcb43f931d9d08b7ab973e18568e9b82.tar.zst
freebsd-ports-gnome-118895acfcb43f931d9d08b7ab973e18568e9b82.zip
Test lack of non-default options for CONFIG-unaware environments
as done in lang/python either. Submitted by: fjoe
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 9123c5f9471f..68a24f15b852 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -43,7 +43,7 @@ OPTIONS= THREADS "Enable thread support" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADS)
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
.if defined(WITHOUT_HUGE_STACK_SIZE)
@@ -57,9 +57,9 @@ CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # defined(WITH_THREADS)
+.endif # !defined(WITHOUT_THREADS)
-.if defined(WITHOUT_UCS2)
+.if !defined(WITHOUT_UCS4) && !defined(WITH_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif