aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-07-10 01:18:00 +0800
committerperky <perky@FreeBSD.org>2004-07-10 01:18:00 +0800
commitc449b850a0b8bb369562e672ca1a6ab510665a04 (patch)
treec853d9c23c5bd17dead9b0db5885aae5e1f7ae0c /lang/python32
parentb3f7c0d5bc5dbb0a364d02679efd645ccff5c175 (diff)
downloadfreebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.tar.gz
freebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.tar.zst
freebsd-ports-gnome-c449b850a0b8bb369562e672ca1a6ab510665a04.zip
Allow to install and use 3rd party packages in X11BASE.
${X11BASE}/lib/{python2.3{,/site-packages},site-python} will be added to your python's sys.path if each directory exists. Suggested by: marcus
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index a9c98c31e232..f36ec2035a9f 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python
PORTVERSION= 2.4.a1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -118,10 +119,13 @@ post-extract:
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
${WRKSRC}/Lib/smtpd.py > ${WRKDIR}/smtpd2.4.py
-post-patch:
- ${REINPLACE_CMD} -e 's,\(PY_VERSION.*\)2\.4a0,\1${PORTVERSION},g' \
- ${WRKSRC}/Include/patchlevel.h
- ${REINPLACE_CMD} -e 's,^.*freenet.*$$,,' ${WRKSRC}/Lib/base64.py
+pre-patch:
+ ${REINPLACE_CMD} -e \
+ 's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
+ ${WRKSRC}/Lib/pydoc.py
+ ${REINPLACE_CMD} -e \
+ 's|^\( *prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ ${WRKSRC}/Lib/site.py
post-configure:
@# prepare a subdir for shared build