aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-06 14:32:22 +0800
committerjgh <jgh@FreeBSD.org>2013-05-06 14:32:22 +0800
commit0ad33b7e0f1e94e8fd60f9d60aa9b63e0c1a4f81 (patch)
tree9e0e39ea77f4f75a3e4e404bd0bbbe59e137f66c /lang/python32
parentbdc5f2384d37bd9f6821542d35f4164fc40881a7 (diff)
downloadfreebsd-ports-gnome-0ad33b7e0f1e94e8fd60f9d60aa9b63e0c1a4f81.tar.gz
freebsd-ports-gnome-0ad33b7e0f1e94e8fd60f9d60aa9b63e0c1a4f81.tar.zst
freebsd-ports-gnome-0ad33b7e0f1e94e8fd60f9d60aa9b63e0c1a4f81.zip
- adoption of USES for gettext
Approved by: portmgr (bapt@)
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 5208a60c49a7..7a571d38f971 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -53,6 +53,17 @@ OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
@@ -68,15 +79,6 @@ PLIST_SUB+= IF_DEFAULT_MAJOR=""
PLIST_SUB+= IF_DEFAULT_MAJOR="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads