aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2012-06-20 01:48:42 +0800
committermva <mva@FreeBSD.org>2012-06-20 01:48:42 +0800
commit8433710b910176e154e19d8cf600c16cda1c74d6 (patch)
treef90a7007559328bce5ab942e6b53ad50fb047d94 /lang/python32
parentf3566c90160390e664f1745e6655d001628fffc1 (diff)
downloadfreebsd-ports-gnome-8433710b910176e154e19d8cf600c16cda1c74d6.tar.gz
freebsd-ports-gnome-8433710b910176e154e19d8cf600c16cda1c74d6.tar.zst
freebsd-ports-gnome-8433710b910176e154e19d8cf600c16cda1c74d6.zip
- Fix gettext detection for the locale module
- Explicitly enable/disable gettext support via a new NLS OPTION switch. PR: ports/168684 ports/136917 On behalf of: python@
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index c0e33286ebcf..041c3e747a9a 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -51,9 +51,11 @@ BIN_FILES= python python-shared python-config python-shared-config \
BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
-OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES
+OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES NLS
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+NLS_DESC= Enable Gettext support for the locale module
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
@@ -63,6 +65,14 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+LDFLAGS+= "-L${LOCALBASE}/lib"
+CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads