aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python33
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-15 02:07:08 +0800
committermiwi <miwi@FreeBSD.org>2017-04-15 02:07:08 +0800
commit3b9c4c816855e489266507060d9a539e204d9a91 (patch)
treeed2b9cf144fe5b527522a9c13da245cd940065c0 /lang/python33
parent452ec5aef93af7dc3c2862528a7a98fb5b06c002 (diff)
downloadfreebsd-ports-gnome-3b9c4c816855e489266507060d9a539e204d9a91.tar.gz
freebsd-ports-gnome-3b9c4c816855e489266507060d9a539e204d9a91.tar.zst
freebsd-ports-gnome-3b9c4c816855e489266507060d9a539e204d9a91.zip
- Fix shebang
Thanks to: amdmi3
Diffstat (limited to 'lang/python33')
-rw-r--r--lang/python33/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 313a7b6564d8..c5a888714ef4 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -16,10 +16,12 @@ LICENSE= PSFL
DEPRECATED= No longer receives bug fixes, only security updates. Please update to Python 3.5
EXPIRATION_DATE= 2017-09-01
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -106,6 +108,8 @@ PLIST_SUB+= NO_NIS=""
.endif
post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
@${REINPLACE_CMD} -e 's/disabled_module_list =[^]]*/&, "nis"/' \
${WRKSRC}/setup.py