aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34/Makefile
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-08-01 23:52:42 +0800
committermva <mva@FreeBSD.org>2014-08-01 23:52:42 +0800
commit2c13788764ee87044681a4c4d5aed55623713ad3 (patch)
treee41121d1987e53e76f03f38fb3d5759276ff050f /lang/python34/Makefile
parentdada92ca68db6a0b6ba697f3777196b5abab68ec (diff)
downloadfreebsd-ports-gnome-2c13788764ee87044681a4c4d5aed55623713ad3.tar.gz
freebsd-ports-gnome-2c13788764ee87044681a4c4d5aed55623713ad3.tar.zst
freebsd-ports-gnome-2c13788764ee87044681a4c4d5aed55623713ad3.zip
- Remove everything related to USE_PYTHON and bsd.python.mk. This is a
preparatory step to convert bsd.python.mk into a USES file. - Use NLS_LIBS instead of NLS_LDFLAGS as done for lang/python27 (r357486) - Use buildbottest in the regression-test: target Phabric: D409 Reviewed by: koobs, sbz With hat: python@
Diffstat (limited to 'lang/python34/Makefile')
-rw-r--r--lang/python34/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 2f4cad8f2d2f..f5530a851b3c 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,11 +3,11 @@
PORTNAME= python34
PORTVERSION= 3.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
-MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
-DISTNAME= ${PYTHON_DISTNAME}
+MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
+DISTNAME= Python-${PORTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -15,18 +15,14 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= ncurses pkgconfig readline tar:xz cpe
+USES= cpe ncurses pkgconfig readline tar:xz
USE_LDCONFIG= yes
-USE_PYTHON= yes
GNU_CONFIGURE= yes
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
CPE_VERSION= ${PORTVERSION}
-PYTHON_VERSION= python3.4
-PYTHON_NO_DEPENDS= yes
-
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
CONFIGURE_ARGS+= --enable-shared --without-ensurepip
CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out OPT to respect user CFLAGS and remove optimizations
@@ -36,7 +32,7 @@ SHAREMODE= 644 # Match upstream INSTALL_DATA=644, so we can STRIP shared
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Override read-only for libraries, so we can STRIP them
MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
-PLIST_SUB= VER=${PYTHON_VER} ABI=${ABIFLAGS} XY=${PYTHON_SUFFIX} \
+PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC
@@ -62,7 +58,7 @@ IPV6_CONFIGURE_ENABLE= ipv6
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
# Upstream Issue: http://bugs.python.org/issue6299
NLS_USES= gettext
-NLS_LDFLAGS= -L${LOCALBASE}/lib
+NLS_LIBS= -L${LOCALBASE}/lib -lintl
NLS_CPPFLAGS= -I${LOCALBASE}/include
NLS_CONFIGURE_ENV_OFF= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
@@ -84,9 +80,9 @@ ABIFLAGS:= d${ABIFLAGS}
.endif
.if !empty(ABIFLAGS)
-PLIST_FILES+= bin/python%%VER%%%%ABI%%
-PLIST_FILES+= bin/python%%VER%%%%ABI%%-config
-PLIST_FILES+= libdata/pkgconfig/python-%%VER%%%%ABI%%.pc
+PLIST_FILES+= bin/python3.4%%ABI%%
+PLIST_FILES+= bin/python3.4%%ABI%%-config
+PLIST_FILES+= libdata/pkgconfig/python-3.4%%ABI%%.pc
.endif
.if ${ARCH} == sparc64
@@ -110,6 +106,6 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpython3.4${ABIFLAGS}.so.1 # Strip shared library
regression-test: build
- @cd ${WRKSRC} && ${MAKE} TESTOPTS=-j${MAKE_JOBS_NUMBER} test
+ @cd ${WRKSRC} && ${MAKE} TESTOPTS=-j${MAKE_JOBS_NUMBER} buildbottest
.include <bsd.port.mk>