aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-06-18 01:09:04 +0800
committerrm <rm@FreeBSD.org>2016-06-18 01:09:04 +0800
commitc1cbb48ab0cc4a2f330cf2a1d65e92c4e91b88d9 (patch)
tree0adb184f75003084e164df487438ff3c51107f45 /lang/python34/Makefile
parent40837b5d2bef8cd865498ea01dab04788be4b13e (diff)
downloadfreebsd-ports-gnome-c1cbb48ab0cc4a2f330cf2a1d65e92c4e91b88d9.tar.gz
freebsd-ports-gnome-c1cbb48ab0cc4a2f330cf2a1d65e92c4e91b88d9.tar.zst
freebsd-ports-gnome-c1cbb48ab0cc4a2f330cf2a1d65e92c4e91b88d9.zip
lang/python[xx]: backport upstream fix for CVE-2016-5636
Add patch for integer overflow in zipimport module to all our python ports. While I'm here, get rid of -f flag in ${RM} invocation, because ${RM} already expands to rm -f, so in result we are getting something like: /bin/rm -f -f /wrkdirs/usr/ports/lang/python35/work/stage/usr/local/lib/libpython3.so PR: 210325 Submitted by: Vladimir Krstulja <vlad-fbsd@acheronmedia.com> Security: 1d0f6852-33d8-11e6-a671-60a44ce6887b With hat: python
Diffstat (limited to 'lang/python34/Makefile')
-rw-r--r--lang/python34/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index acf0d70b9f34..1e02026445e1 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -119,7 +119,7 @@ PLIST_SUB+= NO_NIS=""
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
- ${RM} -f ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.4/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions