aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-11-04 15:33:33 +0800
committerdemon <demon@FreeBSD.org>2014-11-04 15:33:33 +0800
commitf24902a793e389b5457ff2b04995fc6ad47b295a (patch)
treeecfcb6aa0afadf68768567c59dc1f49db7feee89 /lang/python34/Makefile
parent92136b670af0484a1a82dda250e783cac297ea65 (diff)
downloadfreebsd-ports-gnome-f24902a793e389b5457ff2b04995fc6ad47b295a.tar.gz
freebsd-ports-gnome-f24902a793e389b5457ff2b04995fc6ad47b295a.tar.zst
freebsd-ports-gnome-f24902a793e389b5457ff2b04995fc6ad47b295a.zip
Rename option PORT_FFI --> LIBFFI.
Suggested by: koobs
Diffstat (limited to 'lang/python34/Makefile')
-rw-r--r--lang/python34/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index c20cb07844dc..ac193fb0c7f9 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -35,8 +35,8 @@ MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC PORT_FFI
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS PORT_FFI
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS LIBFFI
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
@@ -44,7 +44,7 @@ OPTIONS_SUB= yes
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
TSC_DESC= Enable processor timestamp counter profiling
-PORT_FFI_DESC= Use devel/ffi instead of ffi bundled with Python
+LIBFFI_DESC= Use libffi from ports instead of bundled version
HASH_DESC= Hash Algorithm (PEP-456)
FNV_DESC= Modified Fowler-Noll-Vo Algorithm
@@ -80,7 +80,7 @@ ABIFLAGS:= m${ABIFLAGS}
ABIFLAGS:= d${ABIFLAGS}
.endif
-.if ${PORT_OPTIONS:MPORT_FFI}
+.if ${PORT_OPTIONS:MLIBFFI}
CONFIGURE_ARGS+= --with-system-ffi
LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
.else