aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2015-03-03 21:49:32 +0800
committerdemon <demon@FreeBSD.org>2015-03-03 21:49:32 +0800
commit27d822af6b8e57b4ef0a2d11165e7c6e9c7e5da4 (patch)
treed93fa86a269e61528087adb4cac5ce51e8ddc828 /lang/python34
parent1037a700c917672a9e3c530edd83041d7e95760b (diff)
downloadfreebsd-ports-gnome-27d822af6b8e57b4ef0a2d11165e7c6e9c7e5da4.tar.gz
freebsd-ports-gnome-27d822af6b8e57b4ef0a2d11165e7c6e9c7e5da4.tar.zst
freebsd-ports-gnome-27d822af6b8e57b4ef0a2d11165e7c6e9c7e5da4.zip
Update to version 3.4.3.
https://reviews.freebsd.org/D1991
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile3
-rw-r--r--lang/python34/distinfo4
-rw-r--r--lang/python34/files/patch-issue202108
-rw-r--r--lang/python34/pkg-plist28
4 files changed, 26 insertions, 17 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 246a52f4cfc1..fab86180d8e8 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= python34
-PORTVERSION= 3.4.2
-PORTREVISION= 1
+PORTVERSION= 3.4.3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python34/distinfo b/lang/python34/distinfo
index 7b7b058388b1..fd021e3cdf64 100644
--- a/lang/python34/distinfo
+++ b/lang/python34/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.4.2.tar.xz) = 1c6d9682d145c056537e477bbfa060ce727f9edd38df1827e0f970dcf04b2def
-SIZE (python/Python-3.4.2.tar.xz) = 14223804
+SHA256 (python/Python-3.4.3.tar.xz) = b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8
+SIZE (python/Python-3.4.3.tar.xz) = 14421964
diff --git a/lang/python34/files/patch-issue20210 b/lang/python34/files/patch-issue20210
index 40100a43f42e..38ad041e322c 100644
--- a/lang/python34/files/patch-issue20210
+++ b/lang/python34/files/patch-issue20210
@@ -42,16 +42,16 @@
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
---- ./configure.orig 2014-05-19 05:19:40.000000000 +0000
-+++ ./configure 2014-06-15 12:27:03.000000000 +0000
+--- configure.orig 2015-03-01 13:57:08.000000000 +0300
++++ configure 2015-03-01 13:57:30.000000000 +0300
@@ -650,6 +650,7 @@
TCLTK_LIBS
TCLTK_INCLUDES
LIBFFI_INCLUDEDIR
+DISABLED_EXTENSIONS
+ PKG_CONFIG_LIBDIR
+ PKG_CONFIG_PATH
PKG_CONFIG
- SHLIBS
- CFLAGSFORSHARED
--- ./setup.py.orig 2014-03-24 22:48:48.495472513 +1100
+++ ./setup.py 2014-03-24 22:49:20.076122201 +1100
@@ -33,7 +33,10 @@
diff --git a/lang/python34/pkg-plist b/lang/python34/pkg-plist
index ed6d267d797f..af9c8d6bb360 100644
--- a/lang/python34/pkg-plist
+++ b/lang/python34/pkg-plist
@@ -107,8 +107,8 @@ lib/python3.4/__future__.py
lib/python3.4/__phello__.foo.py
lib/python3.4/__pycache__/__future__.cpython-34.pyc
lib/python3.4/__pycache__/__future__.cpython-34.pyo
-lib/python3.4/__pycache__/__phello__.cpython-34.pyc
-lib/python3.4/__pycache__/__phello__.cpython-34.pyo
+lib/python3.4/__pycache__/__phello__.foo.cpython-34.pyc
+lib/python3.4/__pycache__/__phello__.foo.cpython-34.pyo
lib/python3.4/__pycache__/_bootlocale.cpython-34.pyc
lib/python3.4/__pycache__/_bootlocale.cpython-34.pyo
lib/python3.4/__pycache__/_collections_abc.cpython-34.pyc
@@ -478,6 +478,8 @@ lib/python3.4/asyncio/__pycache__/queues.cpython-34.pyc
lib/python3.4/asyncio/__pycache__/queues.cpython-34.pyo
lib/python3.4/asyncio/__pycache__/selector_events.cpython-34.pyc
lib/python3.4/asyncio/__pycache__/selector_events.cpython-34.pyo
+lib/python3.4/asyncio/__pycache__/sslproto.cpython-34.pyc
+lib/python3.4/asyncio/__pycache__/sslproto.cpython-34.pyo
lib/python3.4/asyncio/__pycache__/streams.cpython-34.pyc
lib/python3.4/asyncio/__pycache__/streams.cpython-34.pyo
lib/python3.4/asyncio/__pycache__/subprocess.cpython-34.pyc
@@ -506,6 +508,7 @@ lib/python3.4/asyncio/proactor_events.py
lib/python3.4/asyncio/protocols.py
lib/python3.4/asyncio/queues.py
lib/python3.4/asyncio/selector_events.py
+lib/python3.4/asyncio/sslproto.py
lib/python3.4/asyncio/streams.py
lib/python3.4/asyncio/subprocess.py
lib/python3.4/asyncio/tasks.py
@@ -1543,8 +1546,8 @@ lib/python3.4/ensurepip/__pycache__/__main__.cpython-34.pyc
lib/python3.4/ensurepip/__pycache__/__main__.cpython-34.pyo
lib/python3.4/ensurepip/__pycache__/_uninstall.cpython-34.pyc
lib/python3.4/ensurepip/__pycache__/_uninstall.cpython-34.pyo
-lib/python3.4/ensurepip/_bundled/pip-1.5.6-py2.py3-none-any.whl
-lib/python3.4/ensurepip/_bundled/setuptools-2.1-py2.py3-none-any.whl
+lib/python3.4/ensurepip/_bundled/pip-6.0.8-py2.py3-none-any.whl
+lib/python3.4/ensurepip/_bundled/setuptools-12.0.5-py2.py3-none-any.whl
lib/python3.4/ensurepip/_uninstall.py
lib/python3.4/enum.py
lib/python3.4/filecmp.py
@@ -1768,8 +1771,6 @@ lib/python3.4/idlelib/__pycache__/run.cpython-34.pyc
lib/python3.4/idlelib/__pycache__/run.cpython-34.pyo
lib/python3.4/idlelib/__pycache__/tabbedpages.cpython-34.pyc
lib/python3.4/idlelib/__pycache__/tabbedpages.cpython-34.pyo
-lib/python3.4/idlelib/__pycache__/testcode.cpython-34.pyc
-lib/python3.4/idlelib/__pycache__/testcode.cpython-34.pyo
lib/python3.4/idlelib/__pycache__/textView.cpython-34.pyc
lib/python3.4/idlelib/__pycache__/textView.cpython-34.pyo
lib/python3.4/idlelib/aboutDialog.py
@@ -1863,7 +1864,6 @@ lib/python3.4/idlelib/macosxSupport.py
lib/python3.4/idlelib/rpc.py
lib/python3.4/idlelib/run.py
lib/python3.4/idlelib/tabbedpages.py
-lib/python3.4/idlelib/testcode.py
lib/python3.4/idlelib/textView.py
lib/python3.4/imaplib.py
lib/python3.4/imghdr.py
@@ -1963,9 +1963,9 @@ lib/python3.4/lib-dynload/unicodedata.so
%%NO_DEBUG%%lib/python3.4/lib-dynload/xxlimited.so
lib/python3.4/lib-dynload/zlib.so
lib/python3.4/lib2to3/Grammar.txt
-lib/python3.4/lib2to3/Grammar3.4.2.final.0.pickle
+lib/python3.4/lib2to3/Grammar3.4.3.final.0.pickle
lib/python3.4/lib2to3/PatternGrammar.txt
-lib/python3.4/lib2to3/PatternGrammar3.4.2.final.0.pickle
+lib/python3.4/lib2to3/PatternGrammar3.4.3.final.0.pickle
lib/python3.4/lib2to3/__init__.py
lib/python3.4/lib2to3/__main__.py
lib/python3.4/lib2to3/__pycache__/__init__.cpython-34.pyc
@@ -2189,8 +2189,11 @@ lib/python3.4/lib2to3/pygram.py
lib/python3.4/lib2to3/pytree.py
lib/python3.4/lib2to3/refactor.py
lib/python3.4/lib2to3/tests/__init__.py
+lib/python3.4/lib2to3/tests/__main__.py
lib/python3.4/lib2to3/tests/__pycache__/__init__.cpython-34.pyc
lib/python3.4/lib2to3/tests/__pycache__/__init__.cpython-34.pyo
+lib/python3.4/lib2to3/tests/__pycache__/__main__.cpython-34.pyc
+lib/python3.4/lib2to3/tests/__pycache__/__main__.cpython-34.pyo
lib/python3.4/lib2to3/tests/__pycache__/pytree_idempotency.cpython-34.pyc
lib/python3.4/lib2to3/tests/__pycache__/pytree_idempotency.cpython-34.pyo
lib/python3.4/lib2to3/tests/__pycache__/support.cpython-34.pyc
@@ -3075,6 +3078,8 @@ lib/python3.4/test/__pycache__/test_sched.cpython-34.pyc
lib/python3.4/test/__pycache__/test_sched.cpython-34.pyo
lib/python3.4/test/__pycache__/test_scope.cpython-34.pyc
lib/python3.4/test/__pycache__/test_scope.cpython-34.pyo
+lib/python3.4/test/__pycache__/test_script_helper.cpython-34.pyc
+lib/python3.4/test/__pycache__/test_script_helper.cpython-34.pyo
lib/python3.4/test/__pycache__/test_select.cpython-34.pyc
lib/python3.4/test/__pycache__/test_select.cpython-34.pyo
lib/python3.4/test/__pycache__/test_selectors.cpython-34.pyc
@@ -3613,6 +3618,7 @@ lib/python3.4/test/sample_doctest.py
lib/python3.4/test/sample_doctest_no_docstrings.py
lib/python3.4/test/sample_doctest_no_doctests.py
lib/python3.4/test/script_helper.py
+lib/python3.4/test/selfsigned_pythontestdotnet.pem
lib/python3.4/test/seq_tests.py
lib/python3.4/test/sgml_input.html
lib/python3.4/test/sha256.pem
@@ -3688,6 +3694,8 @@ lib/python3.4/test/test_asyncio/__pycache__/test_queues.cpython-34.pyc
lib/python3.4/test/test_asyncio/__pycache__/test_queues.cpython-34.pyo
lib/python3.4/test/test_asyncio/__pycache__/test_selector_events.cpython-34.pyc
lib/python3.4/test/test_asyncio/__pycache__/test_selector_events.cpython-34.pyo
+lib/python3.4/test/test_asyncio/__pycache__/test_sslproto.cpython-34.pyc
+lib/python3.4/test/test_asyncio/__pycache__/test_sslproto.cpython-34.pyo
lib/python3.4/test/test_asyncio/__pycache__/test_streams.cpython-34.pyc
lib/python3.4/test/test_asyncio/__pycache__/test_streams.cpython-34.pyo
lib/python3.4/test/test_asyncio/__pycache__/test_subprocess.cpython-34.pyc
@@ -3716,6 +3724,7 @@ lib/python3.4/test/test_asyncio/test_locks.py
lib/python3.4/test/test_asyncio/test_proactor_events.py
lib/python3.4/test/test_asyncio/test_queues.py
lib/python3.4/test/test_asyncio/test_selector_events.py
+lib/python3.4/test/test_asyncio/test_sslproto.py
lib/python3.4/test/test_asyncio/test_streams.py
lib/python3.4/test/test_asyncio/test_subprocess.py
lib/python3.4/test/test_asyncio/test_tasks.py
@@ -4322,6 +4331,7 @@ lib/python3.4/test/test_runpy.py
lib/python3.4/test/test_sax.py
lib/python3.4/test/test_sched.py
lib/python3.4/test/test_scope.py
+lib/python3.4/test/test_script_helper.py
lib/python3.4/test/test_select.py
lib/python3.4/test/test_selectors.py
lib/python3.4/test/test_set.py