aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2015-11-19 09:28:38 +0800
committerlwhsu <lwhsu@FreeBSD.org>2015-11-19 09:28:38 +0800
commit8413c7d9ad977da90646a65d17987594df543101 (patch)
treee9968692ea40cefe464e220ad58f438060131121 /lang/python34
parent3f40dde0dfd669809060b8990dc7badf7295ff84 (diff)
downloadfreebsd-ports-gnome-8413c7d9ad977da90646a65d17987594df543101.tar.gz
freebsd-ports-gnome-8413c7d9ad977da90646a65d17987594df543101.tar.zst
freebsd-ports-gnome-8413c7d9ad977da90646a65d17987594df543101.zip
Add version specified ports of separated standard Python modules for
non-default Python versions: - Add pyXY-{sqlite3,gdbm,tkinter} ports for generating binary packages - Improve/add pkg-message to point users to install respective packages of separated Python standard modules - Add COMMENT to explicitly show the Python version that package should be used with - Simplify version-related PYTHON_* for lang/python35 Reviewed by: koobs Differential Revision: https://reviews.freebsd.org/D4170
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile5
-rw-r--r--lang/python34/files/pkg-message.in10
2 files changed, 14 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 9ca5f3950bc0..036680e5bd1a 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= 3.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -32,6 +32,9 @@ MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
+SUB_FILES= pkg-message
+SUB_LIST= PYTHON_SUFFIX=${PORTVERSION:R:S/.//g}
+
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
diff --git a/lang/python34/files/pkg-message.in b/lang/python34/files/pkg-message.in
new file mode 100644
index 000000000000..c2325386f571
--- /dev/null
+++ b/lang/python34/files/pkg-message.in
@@ -0,0 +1,10 @@
+===========================================================================
+
+Note that some standard Python modules are provided as separate ports
+as they require additional dependencies. They are available as:
+
+py%%PYTHON_SUFFIX%%-gdbm databases/py%%PYTHON_SUFFIX%%-gdbm
+py%%PYTHON_SUFFIX%%-sqlite3 databases/py%%PYTHON_SUFFIX%%-sqlite3
+py%%PYTHON_SUFFIX%%-tkinter x11-toolkits/py%%PYTHON_SUFFIX%%-tkinter
+
+===========================================================================