aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-07-30 11:31:55 +0800
committerkoobs <koobs@FreeBSD.org>2015-07-30 11:31:55 +0800
commit058d0160dc78ce8d6bee816572f6dbc3efb3e028 (patch)
treecdd2249f5a29a1bed0d2579c72c1b75641280768 /lang/python34
parente1c79dfe29b26eedc6dadb752ffc99d2161a5889 (diff)
downloadfreebsd-ports-gnome-058d0160dc78ce8d6bee816572f6dbc3efb3e028.tar.gz
freebsd-ports-gnome-058d0160dc78ce8d6bee816572f6dbc3efb3e028.tar.zst
freebsd-ports-gnome-058d0160dc78ce8d6bee816572f6dbc3efb3e028.zip
lang/python{27,32,33,34}: Mark MAKE_JOBS_UNSAFE
Parser/pgen code intermittently and non-deterministically fails at build time causing errors including, among others: * Parser/pgen.o: file not recognized: File truncated * pgenmain.c:(.text+0x244): undefined reference to `_Py_pgen' This is apparently due to incorrect uses of recursive make [1] which was fixed in the upstream Python 'default' (3.5) branch [2]. This change marks all Python port versions as MAKE_JOBS_UNSANFE until the the original changeset [1] and the resulting regression in cross-builds [3], whos fix is still pending, can be backported. [1] https://bugs.python.org/issue22359 [2] https://hg.python.org/cpython/rev/c2a53aa27cad [3] https://bugs.python.org/issue22625 PR: 200622 Reported by: marino MFH: 2015Q3
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 35b9724620eb..9ca5f3950bc0 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -30,6 +30,7 @@ CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
+MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554