aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
committermarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
commit94df420314debf3fec0a6105e780348971b92ee9 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang/python34
parentdf0b968b2dabb212c7d939f45dd10f5af3fefd84 (diff)
downloadfreebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.gz
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.zst
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.zip
lang/python27(3*), Mk/Uses/python.mk: remove make spawn
There are some inefficiencies in python.mk that significantly slow down full tree scanning. The use of bmake to obtain the current version of a specific python is responsible for the majority of the slow done. This commit splits out the PYTHON_PORTVERSION definition (which is the same as the lang/python* PORTVERSION) into separate files. With this change, python.mk can simple include the makefile fragment instead of spawning a new instance of make. Different Revision: https://reviews.freebsd.org/D4660 Approved by: antoine (python), mva (python)
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile3
-rw-r--r--lang/python34/Makefile.version4
2 files changed, 6 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 82620cc2d7d8..d279ade79085 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= python34
-PORTVERSION= 3.4.3
+PORTVERSION= ${PYTHON_PORTVERSION}
PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
@@ -82,6 +82,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python34/Makefile.version b/lang/python34/Makefile.version
new file mode 100644
index 000000000000..cc944e6b251c
--- /dev/null
+++ b/lang/python34/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.4.3