aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2017-06-06 20:56:47 +0800
committerkoobs <koobs@FreeBSD.org>2017-06-06 20:56:47 +0800
commitd381570cffb4946f0fb26e358a9fa5914bf9b84a (patch)
treedc349266ef50b39f1af7ccb996591cf377357316 /lang/python34
parent46cdd0bfef50ae56da9f2b01d44c257102c08f48 (diff)
downloadfreebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.tar.gz
freebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.tar.zst
freebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.zip
lang/python{27,33,34,35,36}: Install GDB debugging script
Users with a GDB that supports [1] Python extensions will automatically load the extra debugging extensions when debugging programs that are linked with libpythonX.Y.so.foo. This enables extensions like 'py-bt' and 'py-frame' as described in the Fedora Wiki Article: Easier Python Debugging [2], which can be useful for debugging Python program state from crashes in C extensions, for example. [1] PYTHON option enabled in devel/gdb [2] https://fedoraproject.org/wiki/Features/EasierPythonDebugging PR: 203021 Submitted by: cem Reviewed by: mat, koobs (python) Approved by: koobs (python) Differential Revision: D10398
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile4
-rw-r--r--lang/python34/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 1c237230bd91..0a5ec790ece9 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -126,5 +126,7 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.4/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+ ${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
+ ${STAGEDIR}${PREFIX}/lib/libpython3.4${ABIFLAGS}.so.1-gdb.py
.include <bsd.port.mk>
diff --git a/lang/python34/pkg-plist b/lang/python34/pkg-plist
index 17a52edcf0bf..ec468844cade 100644
--- a/lang/python34/pkg-plist
+++ b/lang/python34/pkg-plist
@@ -101,6 +101,7 @@ include/python3.4%%ABI%%/warnings.h
include/python3.4%%ABI%%/weakrefobject.h
lib/libpython3.4%%ABI%%.so
lib/libpython3.4%%ABI%%.so.1
+lib/libpython3.4%%ABI%%.so.1-gdb.py
lib/python3.4/LICENSE.txt
lib/python3.4/__future__.py
lib/python3.4/__phello__.foo.py