aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python35
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
committermarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
commit94df420314debf3fec0a6105e780348971b92ee9 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang/python35
parentdf0b968b2dabb212c7d939f45dd10f5af3fefd84 (diff)
downloadfreebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.gz
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.zst
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.zip
lang/python27(3*), Mk/Uses/python.mk: remove make spawn
There are some inefficiencies in python.mk that significantly slow down full tree scanning. The use of bmake to obtain the current version of a specific python is responsible for the majority of the slow done. This commit splits out the PYTHON_PORTVERSION definition (which is the same as the lang/python* PORTVERSION) into separate files. With this change, python.mk can simple include the makefile fragment instead of spawning a new instance of make. Different Revision: https://reviews.freebsd.org/D4660 Approved by: antoine (python), mva (python)
Diffstat (limited to 'lang/python35')
-rw-r--r--lang/python35/Makefile6
-rw-r--r--lang/python35/Makefile.version4
2 files changed, 7 insertions, 3 deletions
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 097fa497756f..1aa52fa5ae8a 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= python
-DISTVERSION= 3.5.1
+DISTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON/ftp/python/${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
@@ -24,7 +24,6 @@ CPE_PRODUCT= ${CPE_VENDOR}
CPE_VERSION= ${DISTVERSION}
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_PORTVERSION= ${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
PYTHON_VER= ${PYTHON_PORTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -89,6 +88,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python35/Makefile.version b/lang/python35/Makefile.version
new file mode 100644
index 000000000000..bc8460896a75
--- /dev/null
+++ b/lang/python35/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.5.1