aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-13 15:16:45 +0800
committerperky <perky@FreeBSD.org>2006-10-13 15:16:45 +0800
commit3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589 (patch)
tree6c46f1d5bf4bc63b89ba8a1cd88a3898b2377fbc /lang/python
parente7f318bbbc010a1cc2d2a35dcd0ccf78ca6656c2 (diff)
downloadfreebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.tar.gz
freebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.tar.zst
freebsd-ports-gnome-3a81657f5e6e8b2a6d7aed1b68ddf38f2e09c589.zip
Revert the default version of Python to 2.4 for the ports freeze
period. Python 2.5 brought a vast range of incompatibility to a large number of ports, so the python@ team will do more basic compatibility work in a private repository and merge it later. Sorry for the inconvenience. Approved by: portmgr (kris)
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 853ba7705af1..069966fc5f61 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= python
-PORTVERSION= 2.5
+PORTVERSION= 2.4.3
+PORTEPOCH= 1
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
@@ -16,7 +17,7 @@ MAINTAINER= python@FreeBSD.org
COMMENT= The "meta-port" for the stable version of Python interpreter
USE_PYTHON_RUN= yes
-PYTHON_VERSION= python2.5
+PYTHON_VERSION= python2.4
NO_BUILD= yes
do-install: # empty
@@ -26,13 +27,13 @@ PORTUPGRADE?= ${LOCALBASE}/sbin/portupgrade
PKG_WHICH?= ${LOCALBASE}/sbin/pkg_which
upgrade-site-packages:
@if [ -x ${PORTUPGRADE} ]; then \
- for ver in 2.1 2.2 2.3 2.4; do \
+ for ver in 2.1 2.2 2.3 2.5; do \
if [ -d ${PREFIX}/lib/python$$ver ]; then \
UPD=`${FIND} ${PREFIX}/lib/python$$ver \
-type f -print0 | \
${XARGS} -0 ${PKG_WHICH} | \
${GREP} -Fv '?' | \
- ${EGREP} -v '^python2?[0-4]?-2' | \
+ ${EGREP} -v '^python2?[0-5]?-2' | \
${SORT} -u`; \
if [ "$$UPD" ]; then \
${PORTUPGRADE} -f $$UPD; \