aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-07-23 15:49:12 +0800
committertg <tg@FreeBSD.org>1998-07-23 15:49:12 +0800
commitad0e996dbdba0de568b6d19d52e8ca9c0c6aedd8 (patch)
tree483a3376c8e089ace5292b5ccbf6b2fcb0b77c21 /lang/python
parentcc5d7dd9c889df5902bb7ca4020a742fcef39865 (diff)
downloadfreebsd-ports-gnome-ad0e996dbdba0de568b6d19d52e8ca9c0c6aedd8.tar.gz
freebsd-ports-gnome-ad0e996dbdba0de568b6d19d52e8ca9c0c6aedd8.tar.zst
freebsd-ports-gnome-ad0e996dbdba0de568b6d19d52e8ca9c0c6aedd8.zip
Use ldconfig to check for libc_r, not an absolute path. Thread support
should now be compiled in on -current. Suggested by: Jacques Vidrine
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index b7fbb39338b3..ac388ca91a9e 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.34 1998/06/19 09:00:49 tg Exp $
+# $Id: Makefile,v 1.35 1998/06/25 06:43:26 tg Exp $
#
DISTNAME= pyth151
@@ -56,7 +56,8 @@ SETUP_LOCAL= Setup.tk
# This option is enabled by default.
#
WITH_THREADS?= yes
-.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
+LIBC_R!= /sbin/ldconfig -r | grep c_r
+.if ${LIBC_R} != "" && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
CFLAGS+= -D_THREAD_SAFE
CONFIGURE_ENV= LDFLAGS="-pthread ${LDFLAGS}"