aboutsummaryrefslogtreecommitdiffstats
path: root/lang/q/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-03-29 11:18:02 +0800
committerijliao <ijliao@FreeBSD.org>2004-03-29 11:18:02 +0800
commit193d29008e58b1430d943a700f3e2f1268f66424 (patch)
tree2202318ccf7456e2d116a59baa6781a39d274fcd /lang/q/Makefile
parent124cfdec0a0665b1e6bf7d2bae343caa01f4e4bc (diff)
downloadfreebsd-ports-gnome-193d29008e58b1430d943a700f3e2f1268f66424.tar.gz
freebsd-ports-gnome-193d29008e58b1430d943a700f3e2f1268f66424.tar.zst
freebsd-ports-gnome-193d29008e58b1430d943a700f3e2f1268f66424.zip
use stdlib.h instead of malloc.h
Diffstat (limited to 'lang/q/Makefile')
-rw-r--r--lang/q/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index b4457b32caab..23c6f9fc9897 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -76,5 +76,8 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
"s;[(]pkgdatadir[)]/examples;(datadir)/examples/@PACKAGE@;"
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} \
+ ${GREP} -l "<malloc\.h>" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s,<malloc\.h>,<stdlib.h>,"
.include <bsd.port.mk>