aboutsummaryrefslogtreecommitdiffstats
path: root/lang/q
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
committerroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
commitde4cf73f5446a2a8a2c782e21edd36968046a9e7 (patch)
treea8af6bc7bac65179902c59b7a1f9ab026c6203c4 /lang/q
parentf6df9e67cbe8aa509adda747e0c3bcbe05c8c99b (diff)
downloadfreebsd-ports-gnome-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.gz
freebsd-ports-gnome-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.zst
freebsd-ports-gnome-de4cf73f5446a2a8a2c782e21edd36968046a9e7.zip
Update the ftp/curl port to 7.16.0.
Bump PORTREVISION of all dependent ports. Fix the build errors in the few ports that still use the long deprecated, and now obsoleted, cURL options. Thanks to everyone who took the time to look over the patch! Discussed on: -ports
Diffstat (limited to 'lang/q')
-rw-r--r--lang/q/Makefile2
-rw-r--r--lang/q/files/patch-modules-curl-curl.c35
2 files changed, 36 insertions, 1 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index eec9dc5d373c..61f80e866b03 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -7,7 +7,7 @@
PORTNAME= q
PORTVERSION= 6.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= q-lang
diff --git a/lang/q/files/patch-modules-curl-curl.c b/lang/q/files/patch-modules-curl-curl.c
new file mode 100644
index 000000000000..9e9cf77518ff
--- /dev/null
+++ b/lang/q/files/patch-modules-curl-curl.c
@@ -0,0 +1,35 @@
+--- modules/curl/curl.c.orig Fri Dec 8 18:58:07 2006
++++ modules/curl/curl.c Fri Dec 8 18:59:12 2006
+@@ -461,7 +461,9 @@
+ CURLOPT_WRITEFUNCTION,
+ CURLOPT_READFUNCTION,
+ CURLOPT_PROGRESSFUNCTION,
++#if LIBCURL_VERSION_NUM < 0x071000
+ CURLOPT_PASSWDFUNCTION,
++#endif
+ CURLOPT_HEADERFUNCTION,
+ CURLOPT_DEBUGFUNCTION,
+
+@@ -660,7 +662,9 @@
+ mkint(CURLOPT_WRITEFUNCTION),
+ mkint(CURLOPT_READFUNCTION),
+ mkint(CURLOPT_PROGRESSFUNCTION),
++#if LIBCURL_VERSION_NUM < 0x071000
+ mkint(CURLOPT_PASSWDFUNCTION),
++#endif
+ mkint(CURLOPT_HEADERFUNCTION),
+ mkint(CURLOPT_DEBUGFUNCTION),
+
+@@ -964,10 +968,12 @@
+ cb = (int(*)())progress_cb;
+ dataopt = CURLOPT_PROGRESSDATA;
+ break;
++#if LIBCURL_VERSION_NUM < 0x071000
+ case CURLOPT_PASSWDFUNCTION:
+ cb = (int(*)())passwd_cb;
+ dataopt = CURLOPT_PASSWDDATA;
+ break;
++#endif
+ case CURLOPT_HEADERFUNCTION:
+ cb = (int(*)())header_cb;
+ dataopt = CURLOPT_WRITEHEADER;