aboutsummaryrefslogtreecommitdiffstats
path: root/lang/qscheme/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-06-27 22:32:30 +0800
committerwill <will@FreeBSD.org>2002-06-27 22:32:30 +0800
commitb622a506453fdb027cc659e558df7885166ba80e (patch)
tree86cde97b2362e28d94693ae1c26f8adf9c330ab7 /lang/qscheme/Makefile
parentc801b903464d8f1ad23cfa270912c5938e81aef8 (diff)
downloadfreebsd-ports-gnome-b622a506453fdb027cc659e558df7885166ba80e.tar.gz
freebsd-ports-gnome-b622a506453fdb027cc659e558df7885166ba80e.tar.zst
freebsd-ports-gnome-b622a506453fdb027cc659e558df7885166ba80e.zip
Add qscheme 0.5.1, a small and fast Scheme interpreter.
PR: 34999 Submitted by: erik@smluc.org
Diffstat (limited to 'lang/qscheme/Makefile')
-rw-r--r--lang/qscheme/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
new file mode 100644
index 000000000000..738bd4b3871a
--- /dev/null
+++ b/lang/qscheme/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: qscheme
+# Date created: 6 Dec 2001
+# Whom: erik@smluc.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= qscheme
+PORTVERSION= 0.5.1
+CATEGORIES= lang
+MASTER_SITES= http://www.sof.ch/dan/qscheme/files/
+
+MAINTAINER= erik@smluc.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
+ ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+#USE_AUTOCONF= yes
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
+ --with-pcre-inc=${LOCALBASE}/include \
+ --with-avcall-dir=${LOCALBASE}/lib \
+ --with-avcall-inc=${LOCALBASE}/include
+
+.include <bsd.port.mk>