aboutsummaryrefslogtreecommitdiffstats
path: root/lang/qscheme
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
committeredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
commitec40c1b18590a321d5dbd5ebbd73bea024902e87 (patch)
tree8e3df2c273b28d72e1077fa05e7244c8733a9f7a /lang/qscheme
parent7414fe7f0eb5384bcf0deaf5f4587f1c219c904e (diff)
downloadfreebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.gz
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.zst
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.zip
Remove always-false/true conditions based on OSVERSION 500000
Diffstat (limited to 'lang/qscheme')
-rw-r--r--lang/qscheme/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 11ca47e582ec..c536a8eb8da9 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= erik@smluc.org
COMMENT= A small and fast Scheme interpreter
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
- ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+ ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre \
+ ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
GNU_CONFIGURE= yes
@@ -25,7 +26,9 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
--with-pcre-inc=${LOCALBASE}/include \
--with-avcall-dir=${LOCALBASE}/lib \
- --with-avcall-inc=${LOCALBASE}/include
+ --with-avcall-inc=${LOCALBASE}/include \
+ --with-gmp-dir=${LOCALBASE}/lib \
+ --with-gmp-inc=${LOCALBASE}/include
post-patch:
${REINPLACE_CMD} \
@@ -41,10 +44,4 @@ post-patch:
BROKEN= "Does not build on amd64 or ia64"
.endif
-.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+= --with-gmp-dir=${LOCALBASE}/lib \
- --with-gmp-inc=${LOCALBASE}/include
-.endif
-
.include <bsd.port.post.mk>