aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rakudo
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2010-02-18 05:48:19 +0800
committerskv <skv@FreeBSD.org>2010-02-18 05:48:19 +0800
commitf1bd4519ea5827a9bd2c418930a815861cda9eb6 (patch)
tree190eaae9c68023415540b22ddcac05650fe90d3d /lang/rakudo
parentc5a8a0f19e5d0a04097010bd4638c8f38df0d381 (diff)
downloadfreebsd-ports-gnome-f1bd4519ea5827a9bd2c418930a815861cda9eb6.tar.gz
freebsd-ports-gnome-f1bd4519ea5827a9bd2c418930a815861cda9eb6.tar.zst
freebsd-ports-gnome-f1bd4519ea5827a9bd2c418930a815861cda9eb6.zip
- Always require laster Parrot version
- Add Parrot to RUN_DEPENDS - Cleanups Feature safe: yes
Diffstat (limited to 'lang/rakudo')
-rw-r--r--lang/rakudo/Makefile7
-rw-r--r--lang/rakudo/pkg-plist8
2 files changed, 8 insertions, 7 deletions
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index 14711fbd7228..ff64980c8998 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -17,9 +17,10 @@ COMMENT= The Rakudo Perl 6 Compiler targets the Parrot Virtual Machine
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
bison:${PORTSDIR}/devel/bison \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
- parrot_config:${PORTSDIR}/lang/parrot
+ parrot>=${PARROT_VERSION}:${PORTSDIR}/lang/parrot
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
icudata:${PORTSDIR}/devel/icu
+RUN_DEPENDS= parrot>=${PARROT_VERSION}:${PORTSDIR}/lang/parrot
# amd64 i386 sparc
# 9-current pass gcc
@@ -30,11 +31,11 @@ LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
.include <bsd.port.pre.mk>
.if ${ARCH} == 'i386' && ${OSVERSION} >= 900000
-BROKEN= internal gcc bugs
+BROKEN= internal gcc bugs
.endif
.if ${OSVERSION} >= 800000 && ${OSVERSION} <= 900000
-BROKEN= internal gcc bugs
+BROKEN= internal gcc bugs
.endif
.if ${OSVERSION} < 700000
diff --git a/lang/rakudo/pkg-plist b/lang/rakudo/pkg-plist
index 3e72239db6d5..b332d12e50f3 100644
--- a/lang/rakudo/pkg-plist
+++ b/lang/rakudo/pkg-plist
@@ -7,7 +7,7 @@ lib/parrot/%%PARROT_VERSION%%/languages/perl6/lib/Test.pm
lib/parrot/%%PARROT_VERSION%%/languages/perl6/perl6.pbc
@dirrm lib/parrot/%%PARROT_VERSION%%/languages/perl6/lib
@dirrm lib/parrot/%%PARROT_VERSION%%/languages/perl6
-@dirrm lib/parrot/%%PARROT_VERSION%%/languages
-@dirrm lib/parrot/%%PARROT_VERSION%%/dynext
-@dirrm lib/parrot/%%PARROT_VERSION%%
-@dirrm lib/parrot
+@dirrmtry lib/parrot/%%PARROT_VERSION%%/languages
+@dirrmtry lib/parrot/%%PARROT_VERSION%%/dynext
+@dirrmtry lib/parrot/%%PARROT_VERSION%%
+@dirrmtry lib/parrot