aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ratfor
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-01-08 06:55:35 +0800
committermat <mat@FreeBSD.org>2014-01-08 06:55:35 +0800
commit336d58b691c21a2d224a5758dcf28ad2b1b36734 (patch)
tree69c109e6736df041361d55a7aec03094588b3b0f /lang/ratfor
parent83d9272135d4bca0d9452295e64bc5661796a1bf (diff)
downloadfreebsd-ports-gnome-336d58b691c21a2d224a5758dcf28ad2b1b36734.tar.gz
freebsd-ports-gnome-336d58b691c21a2d224a5758dcf28ad2b1b36734.tar.zst
freebsd-ports-gnome-336d58b691c21a2d224a5758dcf28ad2b1b36734.zip
Fix build with gcc47
maintainer timeout PR: ports/184574 Submitted by: Christoph Moench-Tegeder
Diffstat (limited to 'lang/ratfor')
-rw-r--r--lang/ratfor/Makefile1
-rw-r--r--lang/ratfor/files/patch-Makefile20
2 files changed, 13 insertions, 8 deletions
diff --git a/lang/ratfor/Makefile b/lang/ratfor/Makefile
index aa2bb8644946..3549446250f5 100644
--- a/lang/ratfor/Makefile
+++ b/lang/ratfor/Makefile
@@ -26,7 +26,6 @@ USE_FORTRAN= yes
NO_STAGE= yes
post-patch:
@cd ${WRKSRC} ; ${PATCH} --quiet < testw.patch
- @${REINPLACE_CMD} -e 's|%%F77%%|${F77}|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ratfor77 ${PREFIX}/bin
diff --git a/lang/ratfor/files/patch-Makefile b/lang/ratfor/files/patch-Makefile
index 059e3b53747e..2fca4ba2d99e 100644
--- a/lang/ratfor/files/patch-Makefile
+++ b/lang/ratfor/files/patch-Makefile
@@ -1,16 +1,22 @@
---- Makefile~ Sat Jan 13 18:13:44 2007
-+++ Makefile Sat Jan 13 18:14:35 2007
-@@ -28,11 +28,11 @@
+--- Makefile.orig 2013-11-16 17:28:28.000000000 +0100
++++ Makefile 2013-11-16 17:27:51.000000000 +0100
+@@ -26,13 +26,15 @@
+ clean:
+ rm -f *.o *~ ratfor ratfor77 a.out test testw test.f testw.f
- test: ratfor
+-test: ratfor
++test: test.f
++
++test.f: ratfor
./ratfor -o test.f test.r
- f77 -o test test.f
-+ %%F77%% -o test test.f
- testw: ratfor
+-testw: ratfor
++testw: testw.f
++
++testw.f: ratfor
./ratfor -o testw.f testw.r
- f77 -o testw testw.f
-+ %%F77%% -o testw testw.f
tests: test testw
./test