aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ratfor
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-13 17:17:14 +0800
committermaho <maho@FreeBSD.org>2007-01-13 17:17:14 +0800
commit4d2d9ec73673157e680f0ed86824c4d125c51993 (patch)
treef1c6ff6943bcea614d8c8a1d05b119eae3034029 /lang/ratfor
parent7f4b7c977c1c90de60f3f5779a3db4da445452f2 (diff)
downloadfreebsd-ports-gnome-4d2d9ec73673157e680f0ed86824c4d125c51993.tar.gz
freebsd-ports-gnome-4d2d9ec73673157e680f0ed86824c4d125c51993.tar.zst
freebsd-ports-gnome-4d2d9ec73673157e680f0ed86824c4d125c51993.zip
* Migrate to gfortran.
* Bump port revision. Approved by: portmgr(kris)
Diffstat (limited to 'lang/ratfor')
-rw-r--r--lang/ratfor/Makefile6
-rw-r--r--lang/ratfor/files/patch-Makefile16
2 files changed, 22 insertions, 0 deletions
diff --git a/lang/ratfor/Makefile b/lang/ratfor/Makefile
index d5e9ed6585b4..e4c7869d7498 100644
--- a/lang/ratfor/Makefile
+++ b/lang/ratfor/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ratfor
PORTVERSION= 1985.06
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://sepftp.stanford.edu/pub/sep-distr/ \
${MASTER_SITE_LOCAL} \
@@ -25,8 +26,13 @@ EXTRACT_AFTER_ARGS= | ${SH}
ALL_TARGET= all tests
MAN1= ratfor.1
+WANT_FORTRAN=yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+F77= gfortran42
+
post-patch:
@cd ${WRKSRC} ; ${PATCH} --quiet < testw.patch
+ @${REINPLACE_CMD} -e 's|%%F77%%|${F77}|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ratfor77 ${PREFIX}/bin
diff --git a/lang/ratfor/files/patch-Makefile b/lang/ratfor/files/patch-Makefile
new file mode 100644
index 000000000000..059e3b53747e
--- /dev/null
+++ b/lang/ratfor/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile~ Sat Jan 13 18:13:44 2007
++++ Makefile Sat Jan 13 18:14:35 2007
+@@ -28,11 +28,11 @@
+
+ test: ratfor
+ ./ratfor -o test.f test.r
+- f77 -o test test.f
++ %%F77%% -o test test.f
+
+ testw: ratfor
+ ./ratfor -o testw.f testw.r
+- f77 -o testw testw.f
++ %%F77%% -o testw testw.f
+
+ tests: test testw
+ ./test