aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rexx-imc/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-05-29 10:20:47 +0800
committersteve <steve@FreeBSD.org>2000-05-29 10:20:47 +0800
commit359a46f86b02b60865a0e45778df47e1da6d5686 (patch)
tree7e24f5e80cb2ccd43676cd930239fbc07b1da492 /lang/rexx-imc/Makefile
parent8efe0b8a3a99bef2abcc5892b58557923a56cc39 (diff)
downloadfreebsd-ports-gnome-359a46f86b02b60865a0e45778df47e1da6d5686.tar.gz
freebsd-ports-gnome-359a46f86b02b60865a0e45778df47e1da6d5686.tar.zst
freebsd-ports-gnome-359a46f86b02b60865a0e45778df47e1da6d5686.zip
- Support CFLAGS properly
- Fix procedure of building shared library - Sort pkg/PLIST - Revise pkg/DESCR PR: 18797 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'lang/rexx-imc/Makefile')
-rw-r--r--lang/rexx-imc/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/lang/rexx-imc/Makefile b/lang/rexx-imc/Makefile
index 9e1e4811be99..6314cf9785ae 100644
--- a/lang/rexx-imc/Makefile
+++ b/lang/rexx-imc/Makefile
@@ -8,8 +8,8 @@
PORTNAME= rexx-imc
PORTVERSION= 1.7
CATEGORIES= lang
-MASTER_SITES= http://ruby.comlab.ox.ac.uk/imc/distribution/ \
- ftp://ftp.sai.msu.su/pub/unix/rexx/ \
+MASTER_SITES= http://ruby.comlab.ox.ac.uk/imc/distribution/ \
+ ftp://ftp.sai.msu.su/pub/unix/rexx/ \
ftp://crydee.sai.msu.ru/zeus/unix/rexx/
PATCH_SITES= ${MASTER_SITES}
PATCHFILES= ${DISTNAME}-19990331.patch
@@ -17,21 +17,13 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= jfitz@FreeBSD.org
-MAKE_ENV= MKDIR="${MKDIR}"
+MAKE_ENV= MKDIR="${MKDIR}" OPTFLAGS="${CFLAGS}"
MAN1= rexx.1
-.include <bsd.port.pre.mk>
-
-pre-build:
- @ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+post-extract:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
post-install:
-.if ${PORTOBJFORMAT} == "aout"
- @${ECHO_MSG} "Fixing packing list for a.out"
- @${MV} ${TMPPLIST} ${TMPPLIST}.new
- @${GREP} -v '.so$$' ${TMPPLIST}.new > ${TMPPLIST}
- @${RM} ${TMPPLIST}.new
-.endif
@${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>