aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rhino/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-07-06 05:45:01 +0800
committernivit <nivit@FreeBSD.org>2012-07-06 05:45:01 +0800
commitf897da5b3c4c36abaa97f57db7c75d02134ec06f (patch)
tree2225befb8920ed5e8dff85762a1389d4493b3c58 /lang/rhino/Makefile
parent2ce8252fdc5de0ed456efb350c92ac0689417e56 (diff)
downloadfreebsd-ports-gnome-f897da5b3c4c36abaa97f57db7c75d02134ec06f.tar.gz
freebsd-ports-gnome-f897da5b3c4c36abaa97f57db7c75d02134ec06f.tar.zst
freebsd-ports-gnome-f897da5b3c4c36abaa97f57db7c75d02134ec06f.zip
- Update to 1.7.r4
- Remove files/patch-xmlimplsrc+build.xml - Convert to the new options framework - Update MASTER_SITES
Diffstat (limited to 'lang/rhino/Makefile')
-rw-r--r--lang/rhino/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index e6d82cd68264..125c28ddb9f5 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= rhino
-DISTVERSION= 1_7R3
+DISTVERSION= 1_7R4
CATEGORIES= lang java
-MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
+MASTER_SITES= http://cloud.github.com/downloads/mozilla/rhino/:rhino \
http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/:swingex \
- http://www.apache.org/dist/xmlbeans/binaries/:xmlbeans
+ ${MASTER_SITE_APACHE}:xmlbeans
MASTER_SITE_SUBDIR= xmlbeans/binaries/:xmlbeans
DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
src.zip:swingex \
@@ -23,8 +23,6 @@ COMMENT= An implementation of JavaScript written in Java
LICENSE= MPL
-OPTIONS= LINEDIT "Enable line editing in the Rhino shell" on
-
ALL_TARGET= jar
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
@@ -34,10 +32,17 @@ JAVA_VERSION= 1.5+
MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.5.0.zip \
-Dswing-ex-url=file://${DISTDIR}/${DIST_SUBDIR}/src.zip
+OPTIONS_DEFINE= LINEDIT
+LINEDIT_DESC= Enable line editing in the Rhino shell
+
+OPTIONS_DEFAULT= LINEDIT
+
+.include <bsd.port.options.mk>
+
RHINOJAR= ${DATADIR}/${PORTNAME}.jar
SUB_FILES= rhinoc rhinodbg rhinosh
-SUB_LIST= RHINOJAR=${RHINOJAR} JLINEJAR=":${JLINEJAR}"
+SUB_LIST= RHINOJAR=${RHINOJAR} JLINEJAR="${JLINEJAR}"
USE_ANT= yes
USE_JAVA= yes
@@ -55,7 +60,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if defined(WITH_LINEDIT)
+.if ${PORT_OPTIONS:MLINEDIT}
JLINEJAR= ${JAVAJARDIR}/jline.jar
RUN_DEPENDS+= ${JLINEJAR}:${PORTSDIR}/devel/jline
.else