aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rhino
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-08-08 22:05:10 +0800
committerpav <pav@FreeBSD.org>2011-08-08 22:05:10 +0800
commit6424e6c89c764897156a4c4a35265e593881091b (patch)
treed69b33f412292310b1a69da24ef8d66ab75abf20 /lang/rhino
parent68bfea891f0f8130083cae458ac40064b482f505 (diff)
downloadfreebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.tar.gz
freebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.tar.zst
freebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.zip
- Update to 1_7R3 and update xmlbeans to 2.5.0
PR: ports/158438 Submitted by: Pedro Giffuni <giffunip@tutopia.com> Approved by: maintainer timeout (nivit; 1 month)
Diffstat (limited to 'lang/rhino')
-rw-r--r--lang/rhino/Makefile10
-rw-r--r--lang/rhino/distinfo8
-rw-r--r--lang/rhino/files/patch-xmlimplsrc+build.xml22
3 files changed, 31 insertions, 9 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index 35e61d122aa4..e6d82cd68264 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -6,9 +6,7 @@
#
PORTNAME= rhino
-DISTVERSION= 1_7R2
-PORTREVISION= 0
-#PORTEPOCH= 0
+DISTVERSION= 1_7R3
CATEGORIES= lang java
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/:swingex \
@@ -16,13 +14,15 @@ MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
MASTER_SITE_SUBDIR= xmlbeans/binaries/:xmlbeans
DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
src.zip:swingex \
- xmlbeans-2.2.0.zip:xmlbeans
+ xmlbeans-2.5.0.zip:xmlbeans
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}${DISTVERSION}.zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= An implementation of JavaScript written in Java
+LICENSE= MPL
+
OPTIONS= LINEDIT "Enable line editing in the Rhino shell" on
ALL_TARGET= jar
@@ -31,7 +31,7 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
JAVA_VERSION= 1.5+
-MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.2.0.zip \
+MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.5.0.zip \
-Dswing-ex-url=file://${DISTDIR}/${DIST_SUBDIR}/src.zip
RHINOJAR= ${DATADIR}/${PORTNAME}.jar
diff --git a/lang/rhino/distinfo b/lang/rhino/distinfo
index 0d3e62da9c34..1dd9d880925e 100644
--- a/lang/rhino/distinfo
+++ b/lang/rhino/distinfo
@@ -1,6 +1,6 @@
-SHA256 (rhino/rhino1_7R2.zip) = 677f7dc1b67a1587bc03974d5f0720474a56b8f29835e1d860739908df8462dc
-SIZE (rhino/rhino1_7R2.zip) = 2996867
+SHA256 (rhino/rhino1_7R3.zip) = 885b46e24fe5af23ad3712c5e08e8d97d6d92a4b89e1be860e8fe88e4a3dacd1
+SIZE (rhino/rhino1_7R3.zip) = 4651597
SHA256 (rhino/src.zip) = 062837ddb18951ace41ba0050aec95a690c00190a6218e5c9591c381035dfa7d
SIZE (rhino/src.zip) = 19708
-SHA256 (rhino/xmlbeans-2.2.0.zip) = 93632a33292340898015074156cfc2904794c26f310cc9cbe7a00524534360dd
-SIZE (rhino/xmlbeans-2.2.0.zip) = 3720924
+SHA256 (rhino/xmlbeans-2.5.0.zip) = e59cde73e71927365536ef2a3c0fd2459ca85be5a9181e79a9447566ffaa3448
+SIZE (rhino/xmlbeans-2.5.0.zip) = 3793583
diff --git a/lang/rhino/files/patch-xmlimplsrc+build.xml b/lang/rhino/files/patch-xmlimplsrc+build.xml
new file mode 100644
index 000000000000..7a339752778d
--- /dev/null
+++ b/lang/rhino/files/patch-xmlimplsrc+build.xml
@@ -0,0 +1,22 @@
+--- xmlimplsrc/build.xml.orig 2011-05-09 20:04:38.000000000 +0000
++++ xmlimplsrc/build.xml 2011-06-29 10:54:38.000000000 +0000
+@@ -147,7 +147,7 @@
+ <target name="xmlbeans-get" unless="xmlbeans-zip-present?">
+ <property
+ name="xmlbeans.url"
+- value="http://www.apache.org/dist/xmlbeans/binaries/xmlbeans-2.2.0.zip"
++ value="http://www.apache.org/dist/xmlbeans/binaries/xmlbeans-2.5.0.zip"
+ />
+
+ <mkdir dir="${xmlbeans.tmp}" />
+@@ -157,8 +157,8 @@
+ <target name="xmlbeans-unzip" unless="xmlbeans-present?">
+ <antcall target="xmlbeans-get" />
+ <unzip src="${xmlbeans.zip}" dest="${xmlbeans.tmp}" />
+- <copy tofile="${xbean.jar}" file="${xmlbeans.tmp}/xmlbeans-2.2.0/lib/xbean.jar" />
+- <copy tofile="${jsr173.jar}" file="${xmlbeans.tmp}/xmlbeans-2.2.0/lib/jsr173_1.0_api.jar" />
++ <copy tofile="${xbean.jar}" file="${xmlbeans.tmp}/xmlbeans-2.5.0/lib/xbean.jar" />
++ <copy tofile="${jsr173.jar}" file="${xmlbeans.tmp}/xmlbeans-2.5.0/lib/jsr173_1.0_api.jar" />
+ <delete dir="${xmlbeans.tmp}" />
+ </target>
+ </project>