aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rubinius
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /lang/rubinius
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'lang/rubinius')
-rw-r--r--lang/rubinius/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index d5932bc071cf..14968be5135d 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -50,6 +50,7 @@ LLVM38_DESC= LLVM 3.8
LLVM39_DESC= LLVM 3.9
USES= execinfo gmake perl5 readline tar:bzip2 libedit
+USE_LOCALE= en_US.UTF-8
USE_OPENSSL= yes
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
@@ -70,9 +71,6 @@ MAKE_ENV+= HOME=${WRKSRC}
# Hack to switch to a local gem path so locally activated rake can be used
MAKE_ENV+= GEM_PATH=${GEM_PATH}
-# Hack to build under a UTF-8 locale
-MAKE_ENV+= LANG=en_US.UTF-8
-
F_OS= ${OPSYS:tl}
F_MAJOR= ${OSREL:C/\..*$//}
FREEBSD_DIR= ${F_ARCH}-${F_OS}-${F_MAJOR}