aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby-perl/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-11 18:57:44 +0800
committerknu <knu@FreeBSD.org>2000-08-11 18:57:44 +0800
commita026bf9da4bded8b80e9a5965b1446b4f6813643 (patch)
tree98268b1a4c9c168ab79d6056395dc0d8e3ebb372 /lang/ruby-perl/Makefile
parentedd3dc33238204cc6f8ee050322bdebaeafd6641 (diff)
downloadfreebsd-ports-gnome-a026bf9da4bded8b80e9a5965b1446b4f6813643.tar.gz
freebsd-ports-gnome-a026bf9da4bded8b80e9a5965b1446b4f6813643.tar.zst
freebsd-ports-gnome-a026bf9da4bded8b80e9a5965b1446b4f6813643.zip
Add ruby-perl, a Ruby extension module to use the functions of Perl from Ruby.
Diffstat (limited to 'lang/ruby-perl/Makefile')
-rw-r--r--lang/ruby-perl/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
new file mode 100644
index 000000000000..26f55eabef9e
--- /dev/null
+++ b/lang/ruby-perl/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Ruby-perl
+# Date created: 11 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perl
+PORTVERSION= 0.2.5
+CATEGORIES= lang # ruby
+MASTER_SITES= http://www.bekkoame.ne.jp/~yoshidam/
+PKGNAMEPREFIX= ruby-
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+INSTALL_TARGET= site-install
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+USE_PERL5= yes
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+EXAMPLES= htmlparse.rb http.rb perllib.rb ping.rb \
+ test.rb xmlparser.rb
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+ @cd ${WRKSRC}/Ruby; \
+ ${PERL} Makefile.PL
+
+post-build:
+ @cd ${WRKSRC}/Ruby; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
+
+post-install:
+ @cd ${WRKSRC}/Ruby; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
+ ${MKDIR} ${PREFIX}/share/examples/ruby/perl
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/perl/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/perl/ja
+ ${INSTALL_DATA} ${WRKSRC}/README.ja ${PREFIX}/share/doc/ruby/perl/ja/
+.endif
+
+.include <bsd.port.mk>