aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-05-02 01:16:36 +0800
committerknu <knu@FreeBSD.org>2001-05-02 01:16:36 +0800
commit6803ba83c263c7897f08d6448ac8e5df8c52cfaf (patch)
treea34afec86d1728d20bf16ee2c42e97755181ec19 /lang/ruby/Makefile
parent17f0a839a1795abaf2fedf24d4215d651e711e09 (diff)
downloadfreebsd-ports-gnome-6803ba83c263c7897f08d6448ac8e5df8c52cfaf.tar.gz
freebsd-ports-gnome-6803ba83c263c7897f08d6448ac8e5df8c52cfaf.tar.zst
freebsd-ports-gnome-6803ba83c263c7897f08d6448ac8e5df8c52cfaf.zip
Update to the latest snapshot of the ruby_1_6 branch.
- irb 0.7.3 & irb-tools 0.7.1 merged - numerous bugs fixed, including gdbm/dbm memory leakage Strip the binary only when ${STRIP} == -s. La la, still waiting for the 1.6.4 release, la la...
Diffstat (limited to 'lang/ruby/Makefile')
-rw-r--r--lang/ruby/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 9836eeb323f2..b77cf78edef5 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -55,7 +55,9 @@ post-patch:
.endfor
post-install:
+.if ${STRIP} == -s
strip ${RUBY}
+.endif
.if empty(RUBY_SUFFIX)
${MV} -f ${RUBY} ${RUBY}${_RUBY_SUFFIX}
${LN} -fs ${RUBY}${_RUBY_SUFFIX} ${RUBY}
@@ -88,6 +90,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ext/pty/README* ${RUBY_DOCDIR}/pty
${MKDIR} ${RUBY_DOCDIR}/readline
${INSTALL_DATA} ${WRKSRC}/ext/readline/README ${RUBY_DOCDIR}/readline
+ ${CP} -R ${WRKSRC}/doc/irb ${RUBY_DOCDIR}/
.endif
@${CAT} ${PKGMESSAGE}