aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-16 16:46:37 +0800
committerknu <knu@FreeBSD.org>2001-06-16 16:46:37 +0800
commit9540dba52307607fd05c16409daac11b97fcd7cf (patch)
tree0883a76d67797faea5519e1b6733de7c2c7538c7 /lang/ruby/Makefile
parent6346e78f9ba9914fd69b662fb0d9885ac9317f6c (diff)
downloadfreebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.tar.gz
freebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.tar.zst
freebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.zip
Put dummy files in the empty directories so they are surely packed.
Let each elisp port create XEMACSLISPDIR by itself.
Diffstat (limited to 'lang/ruby/Makefile')
-rw-r--r--lang/ruby/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 2cf767ba6893..416f639eb850 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -102,10 +102,12 @@ post-install:
-e ' end;' \
-e 'end' \
${IRB_WITH_SUFFIX}
- ${MKDIR} ${LOCALBASE}/lib/xemacs/site-lisp
${MKDIR} ${RUBY_ELISPDIR}
+ ${TOUCH} ${RUBY_ELISPDIR}/.keep_me
${MKDIR} ${RUBY_EXAMPLESDIR}
+ ${TOUCH} ${RUBY_EXAMPLESDIR}/.keep_me
${MKDIR} ${RUBY_DOCDIR}
+ ${TOUCH} ${RUBY_DOCDIR}/.keep_me
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
${MKDIR} ${RUBY_EXAMPLESDIR}/curses