aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 17:14:09 +0800
committerknu <knu@FreeBSD.org>2002-01-29 17:14:09 +0800
commit4b2d2278de71e9e96ad617179d9de99c457b96c1 (patch)
tree2695cf99ff8eb48ad4cee3a066def8742ca56f5c /lang/ruby16/Makefile
parentc06722dd661943d293f24d271db3dd8f6dd5145d (diff)
downloadfreebsd-ports-gnome-4b2d2278de71e9e96ad617179d9de99c457b96c1.tar.gz
freebsd-ports-gnome-4b2d2278de71e9e96ad617179d9de99c457b96c1.tar.zst
freebsd-ports-gnome-4b2d2278de71e9e96ad617179d9de99c457b96c1.zip
To keep users from experiencing upgrading problems, make lang/ruby and
lang/ruby-devel deinstall obsoleted (integrated) packages in their post-install targets (for installation from ports) and in their plists (for installation from packages), Update to the latest snapshot as of 2002-01-29 while I'm at it.
Diffstat (limited to 'lang/ruby16/Makefile')
-rw-r--r--lang/ruby16/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 238fb7f49964..3fba2b594e1f 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -58,6 +58,8 @@ PLIST_SUB+= IF_DEFAULT=${IF_DEFAULT} \
IRB_WITHOUT_SUFFIX= ${LOCALBASE}/bin/irb
IRB_WITH_SUFFIX= ${IRB_WITHOUT_SUFFIX}${_RUBY_SUFFIX}
+OBSOLETED_MODULES= sha1 shell syslog timex urb uri
+
post-patch:
find ${WRKSRC} -name '*.orig' -delete
.for d in Win32API
@@ -132,6 +134,17 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ext/syslog/syslog.txt ${RUBY_DOCDIR}/syslog
${CP} -R ${WRKSRC}/doc/* ${RUBY_DOCDIR}/
.endif
+ @${ECHO} "Deinstalling obsoleted packages that are now part of ruby..."
+ @cd ${PKG_DBDIR}; for portname in ${OBSOLETED_MODULES}; do \
+ for pkg in ${RUBY_PKGNAMEPREFIX}$$portname-*; do \
+ if [ -d $$pkg ]; then \
+ ${ECHO} "---> $$pkg"; \
+ ${PKG_DELETE} -f $$pkg; \
+ fi; \
+ done; \
+ done
+ @${ECHO_CMD} "@exec ${ECHO_CMD} \"Deinstalling obsoleted packages that are now part of ruby...\"" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec cd ${PKG_DBDIR} && for portname in ${OBSOLETED_MODULES}; do for pkg in ${RUBY_PKGNAMEPREFIX}\$$portname-*; do if [ -d \$$pkg ]; then ${ECHO_CMD} \"---> \$$pkg\"; ${PKG_DELETE} -f \$$pkg; fi; done; done" >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}
test: