aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-09 09:43:01 +0800
committerknu <knu@FreeBSD.org>2001-06-09 09:43:01 +0800
commite8f53dc889e6f0fe03dcc1b844d7b6c592a71d61 (patch)
tree8c2bf01c40fb290762a32e4922b351a7d4d9e5ac /lang/ruby16
parentb29e6c03c811a3e44c5be923768a4a294d4238b3 (diff)
downloadfreebsd-ports-gnome-e8f53dc889e6f0fe03dcc1b844d7b6c592a71d61.tar.gz
freebsd-ports-gnome-e8f53dc889e6f0fe03dcc1b844d7b6c592a71d61.tar.zst
freebsd-ports-gnome-e8f53dc889e6f0fe03dcc1b844d7b6c592a71d61.zip
Dig ${RUBY_EXAMPLESDIR} and ${RUBY_DOCDIR} even if NOPORTDOCS is
defined. (But not actual examples & docs)
Diffstat (limited to 'lang/ruby16')
-rw-r--r--lang/ruby16/Makefile4
-rw-r--r--lang/ruby16/pkg-plist4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index cc2a015dccd9..43762d63c7ea 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -96,14 +96,14 @@ post-install:
-e ' end;' \
-e 'end' \
${IRB_WITH_SUFFIX}
-.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}
+ ${MKDIR} ${RUBY_DOCDIR}
+.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
${MKDIR} ${RUBY_EXAMPLESDIR}/curses
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${RUBY_EXAMPLESDIR}/curses
${MKDIR} ${RUBY_EXAMPLESDIR}/pty
${INSTALL_DATA} ${WRKSRC}/ext/pty/expect_sample.rb ${WRKSRC}/ext/pty/script.rb ${WRKSRC}/ext/pty/shl.rb ${RUBY_EXAMPLESDIR}/pty
- ${MKDIR} ${RUBY_DOCDIR}
${INSTALL_DATA} ${WRKSRC}/README* ${RUBY_DOCDIR}
${MKDIR} ${RUBY_DOCDIR}/etc
${INSTALL_DATA} ${WRKSRC}/ext/etc/etc.txt* ${RUBY_DOCDIR}/etc
diff --git a/lang/ruby16/pkg-plist b/lang/ruby16/pkg-plist
index 417fd351f8f2..9a1f8d748d0f 100644
--- a/lang/ruby16/pkg-plist
+++ b/lang/ruby16/pkg-plist
@@ -157,7 +157,7 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/md5
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/pty
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/readline
-%%PORTDOCS%%@unexec rmdir %D/%%RUBY_DOCDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%RUBY_DOCDIR%% 2>/dev/null || true
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/README
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/biorhythm.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/cal.rb
@@ -216,4 +216,4 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pty/shl.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/curses
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/pty
-%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%
+@dirrm %%RUBY_EXAMPLESDIR%%