aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-02-18 19:24:59 +0800
committerknu <knu@FreeBSD.org>2003-02-18 19:24:59 +0800
commit41d21ee19818d4e7da0a79a8346bc96f0808b68b (patch)
treebd4d1992fdee9691a82a32e35dbf87a284c3337c /lang/ruby16
parentf7fd76a951ae5d149363b81585fc6f8ec5578f45 (diff)
downloadfreebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.tar.gz
freebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.tar.zst
freebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.zip
Touch configure in the pre-configure stage lest the timestamp of
configure.in be ahead of that of configure and autoconf thus be demanded. Submitted: kris, bento
Diffstat (limited to 'lang/ruby16')
-rw-r--r--lang/ruby16/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 9d4fca959bd8..8610d90e11cc 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -92,12 +92,12 @@ OBSOLETED_MODULES= sha1 \
uri
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -106,6 +106,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s