aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-16 16:46:37 +0800
committerknu <knu@FreeBSD.org>2001-06-16 16:46:37 +0800
commit9540dba52307607fd05c16409daac11b97fcd7cf (patch)
tree0883a76d67797faea5519e1b6733de7c2c7538c7 /lang/ruby16
parent6346e78f9ba9914fd69b662fb0d9885ac9317f6c (diff)
downloadfreebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.tar.gz
freebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.tar.zst
freebsd-ports-gnome-9540dba52307607fd05c16409daac11b97fcd7cf.zip
Put dummy files in the empty directories so they are surely packed.
Let each elisp port create XEMACSLISPDIR by itself.
Diffstat (limited to 'lang/ruby16')
-rw-r--r--lang/ruby16/Makefile4
-rw-r--r--lang/ruby16/pkg-plist7
2 files changed, 8 insertions, 3 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 2cf767ba6893..416f639eb850 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -102,10 +102,12 @@ post-install:
-e ' end;' \
-e 'end' \
${IRB_WITH_SUFFIX}
- ${MKDIR} ${LOCALBASE}/lib/xemacs/site-lisp
${MKDIR} ${RUBY_ELISPDIR}
+ ${TOUCH} ${RUBY_ELISPDIR}/.keep_me
${MKDIR} ${RUBY_EXAMPLESDIR}
+ ${TOUCH} ${RUBY_EXAMPLESDIR}/.keep_me
${MKDIR} ${RUBY_DOCDIR}
+ ${TOUCH} ${RUBY_DOCDIR}/.keep_me
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
${MKDIR} ${RUBY_EXAMPLESDIR}/curses
diff --git a/lang/ruby16/pkg-plist b/lang/ruby16/pkg-plist
index 7aaab5fc1563..a29eac98b2f7 100644
--- a/lang/ruby16/pkg-plist
+++ b/lang/ruby16/pkg-plist
@@ -131,7 +131,8 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%RUBYLIB%%@dirrm %%RUBY_LIBDIR%%/shell
%%RUBYLIB%%@dirrm %%RUBY_LIBDIR%%
@unexec rmdir -p %D/lib/xemacs/site-lisp 2>/dev/null || true
-@dirrm %%RUBY_ELISPDIR%%
+%%RUBY_ELISPDIR%%/.keep_me
+@unexec rmdir %D/%%RUBY_ELISPDIR%% 2>/dev/null || true
@unexec rmdir %D/lib/ruby 2>/dev/null || true
%%PORTDOCS%%%%RUBY_DOCDIR%%/NEWS
%%PORTDOCS%%%%RUBY_DOCDIR%%/README
@@ -159,6 +160,7 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/md5
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/pty
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/readline
+%%RUBY_DOCDIR%%/.keep_me
@unexec rmdir %D/%%RUBY_DOCDIR%% 2>/dev/null || true
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/README
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/biorhythm.rb
@@ -218,4 +220,5 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pty/shl.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/curses
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/pty
-@dirrm %%RUBY_EXAMPLESDIR%%
+%%RUBY_EXAMPLESDIR%%/.keep_me
+@unexec rmdir %D/%%RUBY_EXAMPLESDIR%% 2>/dev/null || true