aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16_static
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
committerknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
commit6b623893ecdf432b2870e7f7218c1d3389d45ed9 (patch)
tree8c417f31d71dc4e8992042a279e9a110c7ec5190 /lang/ruby16_static
parent837d4c17a40e1e538f19d84ca605fc8b9c0e5a3d (diff)
downloadfreebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.gz
freebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.zst
freebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.zip
Change the default version of ruby to 1.8 for i386 as well, finally.
Always put a version suffix to the ruby name (no matter if ruby is the default version) to avoid mess in future. [Notes for i386 users] If you are a ruby developer and still want to stick with ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. If you are a ruby developer and want to keep ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. Otherwise, please run the following series of commands to migrate to ruby 1.8: 1) Reinstall portupgrade manually (and ruby 1.8 will be installed) pkg_delete portupgrade-\* (cd /usr/ports/sysutils/portupgrade; make install clean) 2) Reinstall everything that depends on ruby 1.6 (to use ruby 1.8) portupgrade -fr lang/ruby16 3) Reinstall ruby 1.8 (because the previous step kills symlinks) portupgrade -f lang/ruby18 4) Deinstall ruby 1.6 stuff (if you are paranoia) pkg_deinstall -ri lang/ruby16
Diffstat (limited to 'lang/ruby16_static')
-rw-r--r--lang/ruby16_static/Makefile4
-rw-r--r--lang/ruby16_static/pkg-plist2
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index f53a67d07e0f..5e42cc3efecb 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby_static
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= # none
DISTFILES= # none
@@ -128,7 +128,7 @@ do-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
- ${LN} -fs ruby${_RUBY_SUFFIX}_s ${RUBY_WITHOUT_SUFFIX}_s
+ ${LN} -fs ${RUBY_NAME}_s ${RUBY_WITHOUT_SUFFIX}_s
.endif
.include <bsd.port.post.mk>
diff --git a/lang/ruby16_static/pkg-plist b/lang/ruby16_static/pkg-plist
index e8e4eb369d6f..68ba1db162d4 100644
--- a/lang/ruby16_static/pkg-plist
+++ b/lang/ruby16_static/pkg-plist
@@ -1,2 +1,2 @@
%%IF_DEFAULT%%bin/ruby_s
-bin/ruby%%_RUBY_SUFFIX%%_s
+bin/ruby%%RUBY_SUFFIX%%_s