aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-01-12 19:19:20 +0800
committerstas <stas@FreeBSD.org>2009-01-12 19:19:20 +0800
commita143a71a97450fe679a9cebbf59ebe55eedce28e (patch)
tree12fbb55ac4869eb9017d2ff828b9fc50aecb67c6 /lang/ruby18/Makefile
parenta79a1a0c8a476044160be77346893d2694403cb0 (diff)
downloadfreebsd-ports-gnome-a143a71a97450fe679a9cebbf59ebe55eedce28e.tar.gz
freebsd-ports-gnome-a143a71a97450fe679a9cebbf59ebe55eedce28e.tar.zst
freebsd-ports-gnome-a143a71a97450fe679a9cebbf59ebe55eedce28e.zip
- Fix build with OPENSSL_PORT.
PR: ports/130399 Submitted by: bf <bf2006a@yahoo.com>
Diffstat (limited to 'lang/ruby18/Makefile')
-rw-r--r--lang/ruby18/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 546233d2a967..ec8154bdb83f 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -34,6 +34,10 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
_RUBY_SYSLIBDIR= ${PREFIX}/lib
+.ifdef(WITH_OPENSSL_PORT)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ext_openssl_openssl_missing.h
+.endif
+
OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
ONIGURUMA "Build with oniguruma regular expressions lib" off \
GCPATCH "Build with GC performance statistics collector" off \