aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-01-21 12:26:40 +0800
committerume <ume@FreeBSD.org>2006-01-21 12:26:40 +0800
commit12d795e5ae863648e71c9159da76de4a577645aa (patch)
treee44ddf852376f7fe7dc3687836c1d21bab6f46c7 /lang/ruby18
parentdb325885657a13d9d777d771de126491f88c7f15 (diff)
downloadfreebsd-ports-gnome-12d795e5ae863648e71c9159da76de4a577645aa.tar.gz
freebsd-ports-gnome-12d795e5ae863648e71c9159da76de4a577645aa.tar.zst
freebsd-ports-gnome-12d795e5ae863648e71c9159da76de4a577645aa.zip
It was not buildable with CPUTYPE=athlon64 or CPUTYPE=athlon-xp
since my last commit. It spun in 'miniruby' somewhere in a bigdecimal compile. So, if CPUTYPE is defined as athlon64 or athlon-xp, ignore CPU_CFLAGS for workaround. Reported by: Mike Harding <mvh__at__ix.netcom.com>
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 17929f5f0755..cc2fef9fd6b8 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -62,6 +62,10 @@ MAN1= ${RUBY_NAME}.1
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
.endif
+.if ${CPUTYPE} == "athlon64" || ${CPUTYPE} == "athlon-xp"
+WITHOUT_CPU_CFLAGS= yes
+.endif
+
# Uncomment if it still segfaults with 1.8.4
#.if ${ARCH} == "ia64"
#BROKEN= "Segfault during build on ia64"