aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-02-18 19:24:59 +0800
committerknu <knu@FreeBSD.org>2003-02-18 19:24:59 +0800
commit41d21ee19818d4e7da0a79a8346bc96f0808b68b (patch)
treebd4d1992fdee9691a82a32e35dbf87a284c3337c /lang/ruby18
parentf7fd76a951ae5d149363b81585fc6f8ec5578f45 (diff)
downloadfreebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.tar.gz
freebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.tar.zst
freebsd-ports-gnome-41d21ee19818d4e7da0a79a8346bc96f0808b68b.zip
Touch configure in the pre-configure stage lest the timestamp of
configure.in be ahead of that of configure and autoconf thus be demanded. Submitted: kris, bento
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index baa79ab69494..2681751fbffc 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -104,12 +104,12 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -118,6 +118,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s