aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-02-12 22:24:56 +0800
committerstas <stas@FreeBSD.org>2009-02-12 22:24:56 +0800
commit27cc4b05c71a823fab4caf233004c312231cfce3 (patch)
tree0502dc2817b24ae15b98d3ce45ecb88bb50ebbb2 /lang/ruby18
parentd797a6ace4fb44d8c114ea5d642ab9c21459ec48 (diff)
downloadfreebsd-ports-gnome-27cc4b05c71a823fab4caf233004c312231cfce3.tar.gz
freebsd-ports-gnome-27cc4b05c71a823fab4caf233004c312231cfce3.tar.zst
freebsd-ports-gnome-27cc4b05c71a823fab4caf233004c312231cfce3.zip
- Update ruby18 to 1.8.7p72.
PR: ports/124837 (based on) Submitted by: KIMURA Yasuhiro <yasu@utahime.org>
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile9
-rw-r--r--lang/ruby18/distinfo6
-rw-r--r--lang/ruby18/files/patch-io.c10
-rw-r--r--lang/ruby18/files/patch-mkmf.rb16
4 files changed, 25 insertions, 16 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index ec8154bdb83f..dce03936a17e 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -36,6 +36,8 @@ _RUBY_SYSLIBDIR= ${PREFIX}/lib
.ifdef(WITH_OPENSSL_PORT)
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ext_openssl_openssl_missing.h
+.else
+WITH_OPENSSL_BASE= yes # prefer base openssl
.endif
OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
@@ -126,7 +128,6 @@ EXTSAMPLES= bigdecimal/sample/*.rb \
EXTDOCS= bigdecimal/bigdecimal_*.html \
dl/doc/dl.txt \
- enumerator/enumerator.txt \
etc/etc.txt* \
pty/README* \
readline/README* \
@@ -314,4 +315,10 @@ plist::
test:
@(cd ${WRKSRC}; ${MAKE} test)
+validate::
+ @${MKDIR} ${WRKSRC}/rubyspec
+ (cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/rubyspec.git)
+ (cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/mspec.git)
+ (cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${PREFIX}/bin/ruby${RUBY_SUFFIX})
+
.include <bsd.port.post.mk>
diff --git a/lang/ruby18/distinfo b/lang/ruby18/distinfo
index d861dfd5c7ac..45efb4bcc42e 100644
--- a/lang/ruby18/distinfo
+++ b/lang/ruby18/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/ruby-1.8.6-p287.tar.bz2) = 80b5f3db12531d36e6c81fac6d05dda9
-SHA256 (ruby/ruby-1.8.6-p287.tar.bz2) = ac15a1cb78c50ec9cc7e831616a143586bdd566bc865c6b769a0c47b3b3936ce
-SIZE (ruby/ruby-1.8.6-p287.tar.bz2) = 3956902
+MD5 (ruby/ruby-1.8.7-p72.tar.bz2) = 0b215c46b89b28d7ab8d56d96e72d5b9
+SHA256 (ruby/ruby-1.8.7-p72.tar.bz2) = a8f8a28e286dd76747d8e97ea5cfe7a315eb896906ab8c8606d687d9f6f6146e
+SIZE (ruby/ruby-1.8.7-p72.tar.bz2) = 4127450
diff --git a/lang/ruby18/files/patch-io.c b/lang/ruby18/files/patch-io.c
index 2d26a4634ec0..9c663d3027c3 100644
--- a/lang/ruby18/files/patch-io.c
+++ b/lang/ruby18/files/patch-io.c
@@ -1,6 +1,6 @@
---- io.c.orig Thu Mar 2 22:15:47 2006
-+++ io.c Thu Mar 2 22:16:58 2006
-@@ -4682,8 +4682,9 @@
+--- io.c.orig 2008-06-08 22:20:37.000000000 +0400
++++ io.c 2009-02-12 01:10:27.000000000 +0300
+@@ -4970,8 +4970,9 @@
#if !defined(MSDOS) && !defined(__human68k__)
static int
io_cntl(fd, cmd, narg, io_p)
@@ -11,12 +11,12 @@
{
int retval;
-@@ -4713,7 +4714,7 @@
+@@ -5001,7 +5002,7 @@
int io_p;
{
#if !defined(MSDOS) && !defined(__human68k__)
- int cmd = NUM2ULONG(req);
+ unsigned long cmd = NUM2ULONG(req);
- OpenFile *fptr;
+ rb_io_t *fptr;
long len = 0;
long narg = 0;
diff --git a/lang/ruby18/files/patch-mkmf.rb b/lang/ruby18/files/patch-mkmf.rb
index d82c4bca6692..abf56b6a71dd 100644
--- a/lang/ruby18/files/patch-mkmf.rb
+++ b/lang/ruby18/files/patch-mkmf.rb
@@ -1,20 +1,22 @@
---- lib/mkmf.rb.orig Thu Aug 17 09:47:50 2006
-+++ lib/mkmf.rb Wed Aug 30 13:14:44 2006
-@@ -113,8 +113,12 @@
+--- lib/mkmf.rb.orig 2009-02-12 01:18:14.000000000 +0300
++++ lib/mkmf.rb 2009-02-12 01:19:47.000000000 +0300
+@@ -132,9 +132,13 @@
topdir = File.dirname(libdir = File.dirname(__FILE__))
extdir = File.expand_path("ext", topdir)
+setuparchdir = topdir + \
+ "/#{Config::CONFIG["ruby_version"]}/#{Config::CONFIG["arch"]}"
$extmk = File.expand_path($0)[0, extdir.size+1] == extdir+"/"
--if not $extmk and File.exist?(Config::CONFIG["archdir"] + "/ruby.h")
+-if not $extmk and File.exist?(($hdrdir = Config::CONFIG["archdir"]) + "/ruby.h")
+- $topdir = $hdrdir
+if not $extmk and File.exist?(setuparchdir + "/ruby.h")
+ $hdrdir = $topdir = setuparchdir
+elsif not $extmk and File.exist?(Config::CONFIG["archdir"] + "/ruby.h")
- $hdrdir = $topdir = Config::CONFIG["archdir"]
- elsif File.exist?(($top_srcdir ||= topdir) + "/ruby.h") and
++ $topdir = $hdrdir = Config::CONFIG["archdir"]
+ elsif File.exist?(($hdrdir = ($top_srcdir ||= topdir)) + "/ruby.h") and
File.exist?(($topdir ||= Config::CONFIG["topdir"]) + "/config.h")
-@@ -1281,7 +1285,7 @@
+ else
+@@ -1554,7 +1558,7 @@
mfile.print <<-SITEINSTALL