aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
committerknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
commit6b623893ecdf432b2870e7f7218c1d3389d45ed9 (patch)
tree8c417f31d71dc4e8992042a279e9a110c7ec5190 /lang/ruby18
parent837d4c17a40e1e538f19d84ca605fc8b9c0e5a3d (diff)
downloadfreebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.gz
freebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.zst
freebsd-ports-gnome-6b623893ecdf432b2870e7f7218c1d3389d45ed9.zip
Change the default version of ruby to 1.8 for i386 as well, finally.
Always put a version suffix to the ruby name (no matter if ruby is the default version) to avoid mess in future. [Notes for i386 users] If you are a ruby developer and still want to stick with ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. If you are a ruby developer and want to keep ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. Otherwise, please run the following series of commands to migrate to ruby 1.8: 1) Reinstall portupgrade manually (and ruby 1.8 will be installed) pkg_delete portupgrade-\* (cd /usr/ports/sysutils/portupgrade; make install clean) 2) Reinstall everything that depends on ruby 1.6 (to use ruby 1.8) portupgrade -fr lang/ruby16 3) Reinstall ruby 1.8 (because the previous step kills symlinks) portupgrade -f lang/ruby18 4) Deinstall ruby 1.6 stuff (if you are paranoia) pkg_deinstall -ri lang/ruby16
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile12
-rw-r--r--lang/ruby18/pkg-plist14
2 files changed, 13 insertions, 13 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index ca18bc1447d0..5e352c21b0f5 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby${RUBY_R}
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR_RUBY}
@@ -53,7 +53,7 @@ STRIP= # none
.endif
INSTALLS_SHLIB= yes
-MAN1= ruby${_RUBY_SUFFIX}.1
+MAN1= ${RUBY_NAME}.1
LATEST_LINK= ruby-devel
@@ -66,7 +66,7 @@ CONFIGURE_ARGS+= --enable-ipv6
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ruby${_RUBY_SUFFIX}.1 ruby${RUBY_R}.1
+MLINKS= ${RUBY_NAME}.1 ruby${RUBY_R}.1
IF_DEFAULT= ""
.else
IF_DEFAULT= "@comment "
@@ -141,10 +141,10 @@ post-install:
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
# Link just installed "ruby" to "ruby18", etc.
- ${LN} -f ${RUBY_WITHOUT_SUFFIX}${RUBY_R} ${RUBY_WITH_SUFFIX}
- ${LN} -f ${PREFIX}/man/man1/ruby${RUBY_R}.1 ${PREFIX}/man/man1/ruby${_RUBY_SUFFIX}.1
+ ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}${RUBY_R}
+ ${LN} -f ${PREFIX}/man/man1/${RUBY_NAME}.1 ${PREFIX}/man/man1/ruby${RUBY_R}.1
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_R} $${f}${_RUBY_SUFFIX}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
done
.endif
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/lang/ruby18/pkg-plist b/lang/ruby18/pkg-plist
index 80c48e78faae..04b57386b200 100644
--- a/lang/ruby18/pkg-plist
+++ b/lang/ruby18/pkg-plist
@@ -1,17 +1,17 @@
%%IF_DEFAULT%%bin/erb%%RUBY_R%%
-bin/erb%%_RUBY_SUFFIX%%
+bin/erb%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/h2rb%%RUBY_R%%
-bin/h2rb%%_RUBY_SUFFIX%%
+bin/h2rb%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/irb%%RUBY_R%%
-bin/irb%%_RUBY_SUFFIX%%
+bin/irb%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/rdoc%%RUBY_R%%
-bin/rdoc%%_RUBY_SUFFIX%%
+bin/rdoc%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/ri%%RUBY_R%%
-bin/ri%%_RUBY_SUFFIX%%
+bin/ri%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/ruby%%RUBY_R%%
-bin/ruby%%_RUBY_SUFFIX%%
+bin/ruby%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/testrb%%RUBY_R%%
-bin/testrb%%_RUBY_SUFFIX%%
+bin/testrb%%RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%-static.a
lib/lib%%RUBY_NAME%%.so
lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%