aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby20
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-02-11 04:22:20 +0800
committerswills <swills@FreeBSD.org>2014-02-11 04:22:20 +0800
commite8f08fc77f95fb2be84d7bafe332007ccd1fb821 (patch)
treef14ab8fe4edd2202a49d6d8a9f632a277ffb301a /lang/ruby20
parentc20272bdec72fd5e2039c1df8e534a7af9254c7d (diff)
downloadfreebsd-ports-gnome-e8f08fc77f95fb2be84d7bafe332007ccd1fb821.tar.gz
freebsd-ports-gnome-e8f08fc77f95fb2be84d7bafe332007ccd1fb821.tar.zst
freebsd-ports-gnome-e8f08fc77f95fb2be84d7bafe332007ccd1fb821.zip
- Fix build when newer gcc which includes a libffi is installed
PR: ports/186468 Submitted by: Jim Ohlstein <jim@ohlste.in>
Diffstat (limited to 'lang/ruby20')
-rw-r--r--lang/ruby20/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index d18feedb4ca8..63d1256cba3a 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -18,9 +18,12 @@ LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libffi.so:${PORTSDIR}/devel/libffi \
libyaml.so:${PORTSDIR}/textproc/libyaml
+# Using LIB_DEPENDS finds the libffi from gcc which causes problems
+BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+RUN_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \